Bug 2026 - bzflag crashes R200 DRI
bzflag crashes R200 DRI
Status: REOPENED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r200
6.1
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 19:43 UTC by Nicholas Miell
Modified: 2009-06-30 08:14 UTC (History)
2 users (show)

See Also:


Attachments
kernel log from "insmod radeon.ko drm_opts=debug" (23.57 KB, application/binary)
2004-12-06 19:43 UTC, Nicholas Miell
Details
Last 50,000 lines of the client log, created with "R200_DEBUG=all bzflag &> log" (22.33 KB, application/binary)
2004-12-06 19:56 UTC, Nicholas Miell
Details
Xorg log (44.67 KB, text/plain)
2005-06-01 16:31 UTC, Nicholas Miell
Details
Xorg config (2.83 KB, text/plain)
2005-06-01 16:31 UTC, Nicholas Miell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Miell 2004-12-06 19:43:01 UTC
Running bzflag for a short period of time crashes R200 DRI.

This is with an ATI FireGL 8800 on an AMD64 FC3 system running
xorg-x11-6.8.1-12.FC3.21

drm_opts=debug and R200_DEBUG=all logs are will be attached to this bug shortly.
Comment 1 Nicholas Miell 2004-12-06 19:43:56 UTC
Created attachment 1485 [details]
kernel log from "insmod radeon.ko drm_opts=debug"
Comment 2 Nicholas Miell 2004-12-06 19:56:17 UTC
Created attachment 1486 [details]
Last 50,000 lines of the client log, created with "R200_DEBUG=all bzflag &> log"

The entire log compreses to 8.6 MB, which is too large for bugzilla, so here's
the last 50,000 lines.
Comment 3 Alan Cox 2004-12-07 05:40:00 UTC
For reference I run FC3 and play rather to much bzflag on it ith no problems.
That is AMD64,  FC3 update kernel/X, bzflag from FC3 and Radeon 9000Pro. So it
seems any bug is card/system dependant.

Comment 4 Nicholas Miell 2004-12-07 15:40:10 UTC
Oh, and I forgot to mention, this is a SMP system.
Comment 5 Nicholas Miell 2004-12-18 10:43:36 UTC
Can no longer reproduce with xorg-x11-6.8.1.901-1
Comment 6 Nicholas Miell 2005-01-26 17:05:27 UTC
upgraded to bzflag 2.0, it crashes X again

Although, instead of just halting and becoming unresponsive, the monitor now
shuts off.

This is with 6.8.1.902 (which ran bzflag 1.10 just fine).
Comment 7 Eric Anholt 2005-05-31 16:54:15 UTC
Attach your xorg.conf and Xorg.0.log?
Comment 8 Nicholas Miell 2005-06-01 16:31:26 UTC
Created attachment 2812 [details]
Xorg log
Comment 9 Nicholas Miell 2005-06-01 16:31:40 UTC
Created attachment 2813 [details]
Xorg config
Comment 10 Jerome Glisse 2009-06-30 07:48:44 UTC
Do you still have this issue with recent Xorg, kernel, mesa and ddx ?
Comment 11 Nicholas Miell 2009-06-30 08:14:35 UTC
I don't know.

kernel-2.6.29.4-167.fc11.x86_64
kernel-2.6.29.5-191.fc11.x86_64
mesa-dri-drivers-7.6-0.1.fc11.x86_64
mesa-dri-drivers-7.6-0.1.fc11.i586
mesa-libGL-7.6-0.1.fc11.x86_64
mesa-libGL-7.6-0.1.fc11.i586
xorg-x11-server-Xorg-1.6.1.901-1.fc11.x86_64
xorg-x11-drv-ati-6.12.2-18.fc11.x86_64

bzflag fails on startup with:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  129 (XFree86-VidModeExtension)
  Minor opcode of failed request:  10 (XF86VidModeSwitchToMode)
  Value in failed request:  0x104
  Serial number of failed request:  150
  Current serial number in output stream:  152