Bug 20261 - glean case readpixPerf run slow
glean case readpixPerf run slow
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
unspecified
Other Linux (All)
: lowest normal
Assigned To: Eric Anholt
: regression
Depends on:
Blocks: intel-3d-release
  Show dependency treegraph
 
Reported: 2009-02-22 19:13 UTC by liuhaien
Modified: 2009-11-01 22:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (145.34 KB, text/plain)
2009-02-22 19:13 UTC, liuhaien
Details
xorg conf file (3.94 KB, text/plain)
2009-02-22 19:13 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-02-22 19:13:01 UTC
Created attachment 23187 [details]
xorg.0.log

system Environment:
--------------------------
Libdrm:		(master)4d5341340fb6df22fffa7d4a214c54c085a1b1cf
Mesa:		(mesa_7_4_branch)e2092bb23c956ba9ab940935f803ef843db81af2
Xserver:	(server-1.6-branch)4557b3f6c4273cd83b701beaf7a150c806fed298
Xf86_video_intel:		(master)81c652e9a666a7459bcc5217c8a5ec518b6e00da
GEM_kernel:       (drm-intel-2.6.28)fbb12e74c6793652ae323d78fa3312a8787ff021


Bug detailed description:
-------------------------
start X, then run glean,the case blendFunc run too slow (more than 2 hours) on all our platforms recently,but it worked well before Feb.18.we are trying to bisect to find which change cause this issue.

Reproduce steps:
----------------
1. xinit&
2.run Glean/blendFunc
Comment 1 liuhaien 2009-02-22 19:13:30 UTC
Created attachment 23188 [details]
xorg conf file
Comment 2 Eric Anholt 2009-02-22 20:31:55 UTC
We fixed a kernel bug that would have caused unreliable results for the kind of things that glean is doing.  Reliable results meant slower behavior.
Comment 3 liuhaien 2009-02-24 00:05:20 UTC
(In reply to comment #2)
> We fixed a kernel bug that would have caused unreliable results for the kind of
> things that glean is doing.  Reliable results meant slower behavior.
> 

I see,thanks,this issue also impacts readpixPerf.
Comment 4 Gordon Jin 2009-07-01 23:56:43 UTC
texCombine is still slow, even with the new glean option --quick. Haien says it takes about 9~10 hours.
Comment 5 liuhaien 2009-07-02 17:46:29 UTC
(In reply to comment #4)
> texCombine is still slow, even with the new glean option --quick. Haien says it
> takes about 9~10 hours.
> 

hi,
the result I told you was tested two weeks ago and the case seemed like paused in the begining of testing. I retest texCombine last night with the latest build, and it becomes rapid. now it takes 4 hours without option "--quick", and 3 minutes with "--quick".
Comment 6 zhao jian 2009-10-19 22:56:41 UTC
With the newest code, both blendFunc and texCombine passed quickly. Only readpixPerf still runs several hours(it can't finish in 4 hours). 
Libdrm:		(master)3a387a983ec40cd443e22c1f8d9a6b5b5a8fa0d1
Mesa:		(master)074e069910c7082620be4211fe5496365f828886
Xserver:		(master)264ce9e8360374b3a43442c8bdea08abde705446
Xf86_video_intel:	(master)86bc23ab5da34137c82250395c68aa92ecd88a24
Kernel:       (drm-intel-next)8a79060017a16f4bf27467290c597b78230269e2
Comment 7 Eric Anholt 2009-10-30 17:42:38 UTC
At this point --quick is required for quick testing, due to exposing more visuals.  The performance with --quick appears to be acceptable.
Comment 8 zhao jian 2009-11-01 22:27:25 UTC
(In reply to comment #7)
> At this point --quick is required for quick testing, due to exposing more
> visuals.  The performance with --quick appears to be acceptable.

On 945GM, it only takes 2 minutes with --quick option and it without --quick option it will take 2 hours now with the newest code. 
Libdrm:         (master)b0b96636dbf93445dd532b09b21fa4fc5ce6bdc7
Mesa:           (master)1cc16e1b831cef8e1573cc998cee3e55179bb830
Xserver:                (master)d30637339963950910e5f5fb755b8465ac7dddb4
Xf86_video_intel:       (master)10946118dd3a63f1375a1bfde0b2f0542a93c1c2
Kernel: (drm-intel-next)a83a4400415893d2599a256f6842ac4d871dffd7