Bug 20322 - [i965 glean]segfault when run glean case/api2
[i965 glean]segfault when run glean case/api2
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: medium normal
Assigned To: Eric Anholt
:
Depends on:
Blocks: intel-3d-release
  Show dependency treegraph
 
Reported: 2009-02-25 19:34 UTC by liuhaien
Modified: 2009-05-05 00:21 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (48.69 KB, text/plain)
2009-02-25 19:34 UTC, liuhaien
Details
xorg conf file (3.67 KB, text/plain)
2009-02-25 19:34 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-02-25 19:34:18 UTC
Created attachment 23303 [details]
xorg.0.log

System Environment:
--------------------------
Libdrm:		(master)efa485b2cf2f1f46760a3d9297ba1a73a2dbcd05
Mesa:		(mesa_7_4_branch)c32661c3ce39e3c6ba89bb7181692cdf0340c6ca	
Xserver:        (server-1.6-branch)4557b3f6c4273cd83b701beaf7a150c806fed298
Xf86_video_intel: (master)a625a07022ea7f6757b288fcc2ffb9e27c7f8341
GEM_kernel:       (for-airlied)7652afdd9e8ceaa92f34ad347be404b3903ff30f


Bug detailed description:
--------------------------
glean case/api2 got segfault since Feb.18. we find this issue happens at the function testUniformfFuncs(void) of glean/tapi2.cpp because stack corrupted at line 603:
glUniform4fv_func(uf4, 1, expected).

Reproduce steps:
----------------
1.xinit&
2. run glean/api2
Comment 1 liuhaien 2009-02-25 19:34:36 UTC
Created attachment 23304 [details]
xorg conf file
Comment 2 liuhaien 2009-03-22 19:43:22 UTC
still exists against:
Libdrm:         (master)00d8e960ca665b7f0528438331f4d0ae77fbb4cc
Mesa:(mesa_7_4_branch)b009a32bf428192fef2dc4787d25f022a472854f          
Xserver:        (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:       (2.7)e2465249a90b9aefe6d7a96eb56a51fde54698a0
Kernel:       (for-airlied)a2e785c32b886dd7f0289d1cf15fc14e9c81bc01
Comment 3 liuhaien 2009-05-04 18:45:26 UTC
this issue doesn't happen on mesa master and 7_5 branch.
Comment 4 Gordon Jin 2009-05-04 20:02:56 UTC
I guess we can close this.
Comment 5 liuhaien 2009-05-05 00:21:22 UTC
verified with below commits:
Libdrm:		(master)68103b2758029b3c1fbfcf995baa758bfd2676de
Mesa:		(mesa_7_5_branch)0a56a4968786bd93d9117af2a0a3bda13ea71c4d
Xserver:		(master)7d85169c7ab1d05c21fdbb2877ffd79f344dbb6b
Xf86_video_intel:		(master)8255cca2c9092f7ecb798944aa8f03fa3efcfa6c
Kernel:       (for-linus)091438dd5668396328a3419abcbc6591159eb8d1