Bug 20434 - [915GM LVDS] LVDS xrandr issues
Summary: [915GM LVDS] LVDS xrandr issues
Status: RESOLVED DUPLICATE of bug 20265
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: MaLing
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-02 17:29 UTC by Brian De Wolf
Modified: 2009-03-09 16:19 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Verbose Xorg log output of running xrandr twice. (93.13 KB, text/plain)
2009-03-02 17:29 UTC, Brian De Wolf
no flags Details
Verbose Xorg log from rotate. (83.26 KB, text/plain)
2009-03-02 17:29 UTC, Brian De Wolf
no flags Details
Picture of screen in normal orientation. (166.55 KB, image/jpeg)
2009-03-02 17:30 UTC, Brian De Wolf
no flags Details
Picture of screen in inverted orientation. (263.16 KB, image/jpeg)
2009-03-02 17:30 UTC, Brian De Wolf
no flags Details
Xorg log while ignoring TV output. (100.83 KB, text/plain)
2009-03-04 16:39 UTC, Brian De Wolf
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian De Wolf 2009-03-02 17:29:22 UTC
Created attachment 23459 [details]
Verbose Xorg log output of running xrandr twice.

machine: Dell Latitude D610
chipset: 915GM
distro: gentoo
kernel: 2.6.29-rc6
xf86-video-intel: bd360e7517835626bee54bec968cdc78908c6545
xorg-server: 6093d3eb1d7d1e9cbacc2c2f4d376352f787dd53
mesa: 7.3
libdrm: a6dd0afa87558a670f970e61b023f45a396539eb

In all versions that I can test (releases prior to 2.5.1 fail to build), my LVDS display exhibits strange behavior when xrandr is used.  When xrandr is run, regardless of arguments, the elements on the screen shift as though there was a momentary resolution change.  Several lines also appear in the log at the same time (see attached Xorg log, in which I called xrandr twice).  Also, using xrandr rotation on the LVDS screen causes the screen to show lined garbage (see attached image).  I have also included the Xorg log for that as well.

When the X server closes, these lines appear in dmesg:
[drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
mtrr: no MTRR for c0000000,10000000 found

They appear regardless of whether I run xrandr, though.
Comment 1 Brian De Wolf 2009-03-02 17:29:45 UTC
Created attachment 23460 [details]
Verbose Xorg log from rotate.
Comment 2 Brian De Wolf 2009-03-02 17:30:14 UTC
Created attachment 23461 [details]
Picture of screen in normal orientation.
Comment 3 Brian De Wolf 2009-03-02 17:30:34 UTC
Created attachment 23462 [details]
Picture of screen in inverted orientation.
Comment 4 Brian De Wolf 2009-03-02 17:32:22 UTC
The lines that appear in Xorg.log without verbose mode are:

(II) intel(0): I2C bus "CRTDDC_A" initialized.
(II) intel(0): I2C bus "CRTDDC_A" removed.
(II) intel(0): EDID vendor "QDS", prod id 23
(II) intel(0): DDCModeFromDetailedTiming: 1400x1050 Warning: We only handle separate sync.
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1400x1050"x0.0  108.00  1400 1444 1556 1688  1050 1050 1053 1066 -hsync -vsync (64.0 kHz)
(II) intel(0): Modeline "1400x1050"x0.0   90.00  1400 1444 1556 1688  1050 1050 1053 1066 -hsync -vsync (53.3 kHz)
(II) intel(0): EDID vendor "QDS", prod id 23
(II) intel(0): DDCModeFromDetailedTiming: 1400x1050 Warning: We only handle separate sync.
Comment 5 MaLing 2009-03-04 05:01:50 UTC
Hi,
From attachment (id=23459), I see LVDS resolution is only set one time, but there are some TV mode set actions. I think there are no extern displays connecting your laptop(if I was wrong, please correct me), so please use the below method in xorg.conf to ignor it and try again, thanks.

Section "Device"
...
        Option    "monitor-TV"    "TV"
        ...
EndSection
        ...
Section "Monitor" 
        Identifier      "TV" 
        Option          "Ignore" "True" 
EndSection 
Comment 6 Brian De Wolf 2009-03-04 16:38:50 UTC
My laptop does have S-Video out, though I have never used it.  With the ignore TV options added, the screen only "flickers" on the first xrandr call.  I will attach the log from calling xrandr 3 times.

Inverting the display with this option on still does not work.
Comment 7 Brian De Wolf 2009-03-04 16:39:31 UTC
Created attachment 23543 [details]
Xorg log while ignoring TV output.
Comment 8 Michael Fu 2009-03-09 02:11:05 UTC
pls try 

Option "FramebufferCompression" "False"
Option "EXANoComposite" "True"

seperately, to see if any of them will help for the inverted orientation issue.
Comment 9 Brian De Wolf 2009-03-09 12:16:39 UTC
(In reply to comment #8)
> Option "EXANoComposite" "True"

Adding this option makes rotation work.  Yay!
Comment 10 Eric Anholt 2009-03-09 16:19:31 UTC
You meet all the criteria for bug #20265 (2.6.29, pre-965), and from the picture it looks like the same thing.


*** This bug has been marked as a duplicate of bug 20265 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.