Bug 20492 - Took a long time to load a .pdf poster file.
Summary: Took a long time to load a .pdf poster file.
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-05 06:08 UTC by Sebastien Bacher
Modified: 2018-08-20 21:53 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien Bacher 2009-03-05 06:08:44 UTC
The bug has been opened on https://bugs.launchpad.net/bugs/314506

"It took a long time to load a poster.pdf .

This is the error it showed in terminal .

~$ evince poster.pdf
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap
Error: Illegal entry in bfchar block in ToUnicode CMap

When it did show, it is/was sort of grainy.

If there is some sort font which is missing, it should show in some understandable manner.

http://launchpadlibrarian.net/20959731/poster.pdf
The poster in question can be found at http://madsrh.googlepages.com/poster.pdf
I can confirm the error messages and the graininess. However, please note that the graininess goes away when zooming in... Opened also in acroread 8, no errors, no graininess (however, zoom in to 150% and the graininess goes away also in evince).
The fonts included are "Calibri" and "Ubuntu-Title""
Comment 1 Albert Astals Cid 2009-03-08 05:01:02 UTC
Define long time please, 1 second, 1 minute, 1 hour, 1 day?

The font grainyness seem present only in the cairooutputdev, poppler master is supposed to have some fixes about fonts in the cairooutputdev but i can't test it because it needs a too new cairo, Carlos can you please test?
Comment 2 Carlos Garcia Campos 2009-03-08 10:25:22 UTC
(In reply to comment #1)
> Define long time please, 1 second, 1 minute, 1 hour, 1 day?

4.5 seconds with poppler-glib-demo

> The font grainyness seem present only in the cairooutputdev, poppler master is
> supposed to have some fixes about fonts in the cairooutputdev but i can't test
> it because it needs a too new cairo, Carlos can you please test?
> 

fonts issue is present in git master too.
Comment 3 Albert Astals Cid 2009-03-08 11:53:29 UTC
4.5s doesn't seem "too long" to me, moving to cairo outputdev component as the font problem is the only problem i really see in this pdf.
Comment 4 Peter Funk 2009-09-17 08:19:10 UTC
I stumbled over this bug report while searching the web on 
with the error message 
"Error: Illegal entry in bfchar block in ToUnicode CMap"
I saw this message displayed while trying to view a PDF file
generated by Adobe Indesign CS4 (Adobe PDF Library 9.0) with
evince (Ubuntu 9.4 Jaunty with poppler-utils 0.10.5-1ubuntu2).

In my case this particular PDF displays wrong results
(compared to what Adobe Acrobat 8.0 shows and what the creator
of this particular PDF obviously intended):  Certain text
is missing!  Unfortunately I'm not allowed to attach this
particular problematic PDF because it contains confidential info.
Comment 5 Albert Astals Cid 2009-09-17 14:08:29 UTC
Peter, without the pdf there is nothing we can do, if you send it to me i can have a look and put it on my files to never share. Otherwise we can't do anything.
Comment 6 Carlos Garcia Campos 2010-01-25 02:56:06 UTC
It takes mostly the same time in splash and cairo backend, I see the same error messages with both too and the fonts rendering issue is fixed in git master now (bug #5589). Do we move this to general because of the rendering time? or just close it as fixed because of the font rendering?
Comment 7 shirishag75 2012-01-24 10:03:25 UTC
Hi all, 
I am on Debian sid now and this issue is still there. 

Error: Illegal entry in bfchar block in ToUnicode CMap

It does not matter what app I use get the same issue. 


$ epdfview cellit.pdf 
Error: Illegal entry in bfchar block in ToUnicode CMap


$ xpdf cellit.pdf 
Error: Illegal entry in bfchar block in ToUnicode CMap

and it takes quite a bit of time to open up (more than a minute) the file. This is on Pentium Dual-core. The error comes out multiple times. 

One can find the pdf I was opening at http://cellit.co.in/ui_images/magazines/pdf/Magazine-1-2012-33.pdf . I just renamed it to cellit so I remember.
Comment 8 shirishag75 2012-01-24 10:18:22 UTC
$ apt-show-versions -a libpoppler13
libpoppler13 0.16.7-2+b1 install ok installed
No stable version
libpoppler13 0.16.7-2+b1 testing  ftp.au.debian.org
libpoppler13 0.16.7-2+b1 unstable ftp.au.debian.org
Comment 9 GitLab Migration User 2018-08-20 21:53:20 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/110.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.