Bug 20495 - protected_change_timeout no thread safe
Summary: protected_change_timeout no thread safe
Status: RESOLVED DUPLICATE of bug 17754
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: Other All
: medium major
Assignee: Havoc Pennington
QA Contact: John (J5) Palmieri
Depends on:
Reported: 2009-03-05 07:25 UTC by Johan Gyllenspetz
Modified: 2009-03-05 10:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Johan Gyllenspetz 2009-03-05 07:25:08 UTC
protected_change_timeout will return false if an other thread is reorganising timeouts. This is OK in most cases but this will cause dbus_connection_send_with_reply to error out (with out of memory as error) when it calls _dbus_connection_attach_pending_call_unlocked if an other thread is removing a timeout while its called.
Comment 1 Havoc Pennington 2009-03-05 10:54:18 UTC

*** This bug has been marked as a duplicate of bug 17754 ***

bug/show.html.tmpl processed on Oct 27, 2016 at 12:44:34.
(provided by the Example extension).