Bug 20612 - nouveau xv crash with BadMatch (invalid parameter attributes)
Summary: nouveau xv crash with BadMatch (invalid parameter attributes)
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-11 16:25 UTC by Xavier
Modified: 2011-02-15 03:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg log (30.85 KB, text/plain)
2009-03-11 16:25 UTC, Xavier
no flags Details
I just noticed many errors in dmesg, attaching the relevant part. (2.26 KB, text/plain)
2009-03-11 16:34 UTC, Xavier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier 2009-03-11 16:25:48 UTC
Created attachment 23772 [details]
xorg log

Using nouveau drm and xorg driver from git 20090303,
with GeForce 8600M GT card (in a laptop).

I cannot play anything using the xv driver.

With mplayer, it loops and I get no image :
X11 error: BadMatch (invalid parameter attributes)?% ??% ??,?% 0 0 
X11 error: BadMatch (invalid parameter attributes)?% ??% ??,?% 0 0 
X11 error: BadMatch (invalid parameter attributes)?% ??% ??,?% 0 0 
X11 error: BadMatch (invalid parameter attributes)?% ??% ??,?% 0 0 
X11 error: BadMatch (invalid parameter attributes)?% ??% ??,?% 0 0 
X11 error: BadMatch (invalid parameter attributes)?% ??% ??,?% 0 0 
...

With xine, it just crashes :
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  132 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  2021
  Current serial number in output stream:  2022

xvinfo output :
X-Video Extension version 2.2
screen #0
  Adaptor #0: "Nouveau GeForce 8/9 Textured Video"
    number of ports: 32
    port base: 63
    operations supported: PutImage 
    supported visuals:
      depth 24, visualID 0x21
      depth 24, visualID 0x22
    no port attributes defined
    maximum XvImage size: 4096 x 4096
    Number of image formats: 3
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
Comment 1 Xavier 2009-03-11 16:34:15 UTC
Created attachment 23773 [details]
I just noticed many errors in dmesg, attaching the relevant part.
Comment 2 Ben Skeggs 2009-03-11 19:15:27 UTC
Unfortunately this is the current expected behaviour.  If you run an XRENDER base composite manager (xcompmgr is fine) Xv will work.  Hopefully we'll be able to remove this limitation in the future.

The errors you mentioned are also expected, and harmless.  We're looking at what's going wrong there however :)
Comment 3 Xavier 2009-03-12 03:00:58 UTC
(In reply to comment #2)
> Unfortunately this is the current expected behaviour.  If you run an XRENDER
> base composite manager (xcompmgr is fine) Xv will work.  Hopefully we'll be
> able to remove this limitation in the future.
> 
> The errors you mentioned are also expected, and harmless.  We're looking at
> what's going wrong there however :)
> 

I just enabled composite in xorg.conf (not enabled by default), and started xcompmgr -a, and xv works perfectly now, thanks!

However I could not find anything when searching for this issue, is it mentioned somewhere?
I did not find existing bug reports, and maybe this limitation could also be mentioned on the main page ( http://nouveau.freedesktop.org/wiki/ ) since there is a decent workaround.
Comment 4 Adam Petaccia 2009-03-12 15:44:56 UTC
(In reply to comment #3)
> However I could not find anything when searching for this issue, is it
> mentioned somewhere?
> I did not find existing bug reports, and maybe this limitation could also be
> mentioned on the main page ( http://nouveau.freedesktop.org/wiki/ ) since there
> is a decent workaround.
> 

I've updated the wiki on the two relevent pages I know about (FeatureMatrix and XVideoStatus) to note this issue.
Comment 5 Xavier 2009-03-12 17:25:25 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > However I could not find anything when searching for this issue, is it
> > mentioned somewhere?
> > I did not find existing bug reports, and maybe this limitation could also be
> > mentioned on the main page ( http://nouveau.freedesktop.org/wiki/ ) since there
> > is a decent workaround.
> > 
> 
> I've updated the wiki on the two relevent pages I know about (FeatureMatrix and
> XVideoStatus) to note this issue.
> 

Looks good, thanks.
Comment 6 Xavier 2011-02-15 03:02:33 UTC
this has been resolved ages ago.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.