Bug 20698 - Java AWT applications extremly slow
Java AWT applications extremly slow
Status: RESOLVED WONTFIX
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
Other All
: medium normal
Assigned To: Gordon Jin
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 13:44 UTC by Clemens Eisserer
Modified: 2009-03-18 01:55 UTC (History)
0 users

See Also:


Attachments
compiled test-case (1007 bytes, application/octet-stream)
2009-03-16 13:44 UTC, Clemens Eisserer
no flags Details
test case's source (634 bytes, application/octet-stream)
2009-03-16 13:44 UTC, Clemens Eisserer
no flags Details
small code excerpt how java blits glyphs (3.18 KB, text/plain)
2009-03-16 13:48 UTC, Clemens Eisserer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2009-03-16 13:44:03 UTC
Created attachment 23929 [details]
compiled test-case

I noticed that problem when using a Java AWT based chat applet, it was extremly slow up to the point where it was really annoying to use.

I created a small stand-alone test-case which can be executed with:
"java IntelPerfTest"

in the same directory where the file IntelPerfTest.class is located.
If you don't want to use the precompiled class file, feel free to compile the source with "javac IntelPerfTest.java".

Please scroll a bit arround or resize the window.

I guess part of the problem is the strange way Java renders non-antialiased text, uploading a 1-bit image, and using that as stipple.
This will be replaced by Java7 hopefully, however it shouldn't be *that* slow anyway. (worked well with EXA and XAA).
Comment 1 Clemens Eisserer 2009-03-16 13:44:42 UTC
Created attachment 23930 [details]
test case's source
Comment 2 Clemens Eisserer 2009-03-16 13:48:28 UTC
Created attachment 23931 [details]
small code excerpt how java blits glyphs
Comment 3 Clemens Eisserer 2009-03-17 12:25:11 UTC
just noticed that the demo is much more responsive when a composition manager is used - its still slow but useable.
Without one, its very slow - real world applets are hardly useable anymore.
Comment 4 Eric Anholt 2009-03-17 18:29:33 UTC
We don't intend to fix this in UXA ourselves.  If you're drawing unantialiased text in 2009, your software fails.  If you're not using Xft or cairo for text drawing in 2009, your software fails even harder (it would perform fine if you were).

We would consider applying patches if they were posted.
Comment 5 Clemens Eisserer 2009-03-18 01:55:56 UTC
Well first of all this is not "my" software. It has been written ~15 years ago and worked well since then on all acceleration architectures.
However the problem is not isolated, it appears that fallbacks in general seem to be really expensive - way more than they are when using EXA.

So I am just an angry consumer, whose software has been broken, wondering why OpenGL on his intel chip is still too slow to play any games on it at serious resolutions (as it has always been), while on windows it does about 3 times the fps.

> We don't intend to fix this in UXA ourselves.
I don't intend to fix it either. This UXA stuff is "yours".