Bug 20821 - [GLSL] shadow_sampler was incorrect rendered
[GLSL] shadow_sampler was incorrect rendered
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: medium normal
Assigned To: Ian Romanick
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 02:34 UTC by zhao jian
Modified: 2009-09-07 20:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (47.25 KB, text/plain)
2009-03-24 02:34 UTC, zhao jian
Details
shadow_sampler was incorrectly rendered (11.92 KB, image/png)
2009-03-24 02:36 UTC, zhao jian
Details
shadow_sampler run with software raster (11.91 KB, image/png)
2009-03-24 02:37 UTC, zhao jian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhao jian 2009-03-24 02:34:02 UTC
Created attachment 24183 [details]
xorg.0.log

System Environment:
----------------------
Platform:               g45
Arch:           x86_64
OSD:            Fedora release 8 (Werewolf)
Kernel_version:         2.6.29-rc7
Libdrm: (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa: (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver: (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel: (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf
Kernel: (for-airlied)dc529a4fe1ae4667c819437a94185e8581e1e680

Bug Description:
---------------------
On both G45 and Gm965, the mesa/progs/glsl/shadow_sampler was incorrect rendered. As the attached picture shows. It fails both with UXA and
EXA. 

Reproduce Steps:
---------------------
1. xinit&
2. run mesa/progs/glsl/shadow_sampler
Comment 1 zhao jian 2009-03-24 02:36:21 UTC
Created attachment 24184 [details]
shadow_sampler was incorrectly rendered
Comment 2 zhao jian 2009-03-24 02:37:00 UTC
Created attachment 24185 [details]
shadow_sampler run with software raster
Comment 3 Ian Romanick 2009-07-07 13:20:23 UTC
If I change USE_RECT to 0, this test works correctly on Mesa master and the 7.5 branch.  Note that the output is slightly different because linear filtering of shadow maps does percentage-closer filtering on i965 class hardware.

Until shadow sampling from texture rectangles is fixed, I will leave this bug open.
Comment 4 Eric Anholt 2009-08-04 12:43:57 UTC
anholt@gaiman:mesa/progs/glsl% git log origin/master..191e028de20b2f954621b652aa77b06d0e93652a
commit 191e028de20b2f954621b652aa77b06d0e93652a
Author: Eric Anholt <eric@anholt.net>
Date:   Tue Aug 4 12:39:22 2009 -0700

    i965: Fix RECT shadow sampling by not losing the other texcoords.
    
    Bug #20821
Comment 5 zhao jian 2009-09-07 20:26:45 UTC
verified on GM965 with 
Libdrm: (master) 73b59c894380995a2889b98e79acadd2da0bb237
Mesa: (master)  8126dfa9c24c972794193bf652d6d09a1d01b376
Xserver: (server-1.6-branch)3044711412d0a08ba65a491bd2441c0c8980f5e2
Xf86_video_intel: (master)5812531e08147576de776b2dd64e7f94c08eb851
Kernel: (master) 326ba5010a5429a5a528b268b36a5900d4ab0eba