Bug 20878 - Xorg server does not properly autodetect dual nVidia graphics cards
Xorg server does not properly autodetect dual nVidia graphics cards
Status: RESOLVED DUPLICATE of bug 18321
Product: xorg
Classification: Unclassified
Component: Server/General
7.4 (2008.09)
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Nouveau Project
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 05:42 UTC by Stephen Gallagher
Modified: 2009-03-26 10:46 UTC (History)
0 users

See Also:


Attachments
X.org log demonstrating the error (7.69 KB, application/octet-stream)
2009-03-26 05:42 UTC, Stephen Gallagher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Gallagher 2009-03-26 05:42:50 UTC
Created attachment 24273 [details]
X.org log demonstrating the error

When starting the X server, it detects that there are "More than one possible primary device found"

(!!) More than one possible primary device found
(--) PCI: (0@3:0:0) nVidia Corporation G94 [GeForce 9600 GT] rev 161, Mem @ 0xf4000000/16777216, 0xc0000000/268435456, 0xf2000000/33554432, I/O @ 0x0000ac00/128, BIOS @ 0x????????/524288
(--) PCI: (0@5:0:0) nVidia Corporation G94 [GeForce 9600 GT] rev 161, Mem @ 0xf8000000/16777216, 0xd0000000/268435456, 0xf6000000/33554432, I/O @ 0x00008c00/128, BIOS @ 0x????????/524288


The X server will then attempt to invoke the VESA driver instead of the Nouveau driver (this is on the Fedora 11 Nouveau Test Day LiveCD)

Ultimately it will fail with:
Fatal server error:
AddScreen/ScreenInit failed for driver 0


However, if I manually add the following to an xorg.conf file, it loads correctly.
Section "Device"
	Identifier  "Videocard0"
	BusID       "PCI:3:0:0"
	Driver      "nouveau"
EndSection

Section "Device"
	Identifier	"Videocard1"
	BusID		"PCI:5:0:0"
	Driver		"nouveau"
EndSection


The correct behavior of the X server should be to automatically generate these entries for each card.
Comment 1 Julien Cristau 2009-03-26 10:46:28 UTC

*** This bug has been marked as a duplicate of bug 18321 ***