Bug 20881 - APT backend failed, gpk unable to get list of pacakges
Summary: APT backend failed, gpk unable to get list of pacakges
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-apt (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-26 09:11 UTC by Michael Vasiliev
Modified: 2012-01-05 10:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
packagekitd work log (17.64 KB, application/octet-stream)
2009-03-26 09:19 UTC, Michael Vasiliev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Vasiliev 2009-03-26 09:11:48 UTC
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/packagekit/daemonBackend.py", line 109, in run
    threading.Thread.run(self)
  File "/usr/lib/python2.5/threading.py", line 446, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.5/site-packages/packagekit/aptbackend.py", line 892, in doGetRepoList
    repos = PackageKitSoftwareProperties()
  File "/var/lib/python-support/python2.5/softwareproperties/SoftwareProperties.py", line 50, in __init__
    self.distro = aptsources.distro.get_distro()
AttributeError: 'module' object has no attribute 'distro'
Comment 1 Michael Vasiliev 2009-03-26 09:19:51 UTC
Created attachment 24277 [details]
packagekitd work log

while start gpk-application
Comment 2 Michael Vasiliev 2009-03-26 09:27:16 UTC
Has been builded form tarball on Debian Lenny x86_64
PackageKit-0.4.5
gnome-packagekit-0.4.5
Comment 3 Jean-François Fortin Tam 2012-01-05 10:34:54 UTC
Hi there,
This bug report is very old and based on a version not supported anymore. By upgrading to a newer version of PackageKit you could receive bug fixes and new functionality. You may need to upgrade your Linux distribution to obtain a newer version of PackageKit.
Please feel free to reopen this bug if the problem still occurs with the latest version.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.