Bug 20890 - screen corruption on intel in some cases
Summary: screen corruption on intel in some cases
Status: RESOLVED DUPLICATE of bug 20803
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-26 13:52 UTC by Arkadiusz Miskiewicz
Modified: 2009-03-26 19:04 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg log (24.75 KB, text/plain)
2009-03-26 13:52 UTC, Arkadiusz Miskiewicz
no flags Details
when viewing http://filmfactor.pl/ in firefox (794.16 KB, image/png)
2009-03-26 13:53 UTC, Arkadiusz Miskiewicz
no flags Details
on kde4 logout screen (345.67 KB, image/png)
2009-03-26 13:53 UTC, Arkadiusz Miskiewicz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arkadiusz Miskiewicz 2009-03-26 13:52:49 UTC
Created attachment 24290 [details]
xorg log

In some cases when using intel driver the screen is corrupted.

This happens on:
xserver 1.6
intel driver from master
libdrm from master
drm from drm-intel-next

but only if KMS is disabled.
Comment 1 Arkadiusz Miskiewicz 2009-03-26 13:53:33 UTC
Created attachment 24291 [details]
when viewing http://filmfactor.pl/ in firefox
Comment 2 Arkadiusz Miskiewicz 2009-03-26 13:53:54 UTC
Created attachment 24292 [details]
on kde4 logout screen
Comment 3 Arkadiusz Miskiewicz 2009-03-26 13:55:26 UTC
Note that this corruption is easy to repeat but it's specific. For example it is visible only on some web pages and in kde so far only on logout screen. The rest looks fine.
Comment 4 Gordon Jin 2009-03-26 18:53:54 UTC
looks like bug#20803.
Comment 5 Jesse Barnes 2009-03-26 19:04:49 UTC
Yep, marking as a dup

*** This bug has been marked as a duplicate of bug 20803 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.