Bug 21193 - [uxa]glean case/makeCurrent crash X with dri2
[uxa]glean case/makeCurrent crash X with dri2
Status: VERIFIED DUPLICATE of bug 20291
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
unspecified
Other Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-15 00:43 UTC by liuhaien
Modified: 2009-07-02 00:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (62.08 KB, text/plain)
2009-04-15 00:43 UTC, liuhaien
Details
xorg conf file (3.67 KB, text/plain)
2009-04-15 00:50 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-04-15 00:43:01 UTC
Created attachment 24811 [details]
xorg.0.log

System Environment:
--------------------------
Host:		x-945gm
Arch:		i386
Platform:		945GM
OSD:		Fedora release 9 (Sulphur)
Kernel_version:		2.6.29.1
Libdrm:		(master)07646002c6835537c6ae44ef9b3f8480762279b8
Mesa:		(mesa_7_4_branch)de197cf991416f0cd65ad2e2d2ca9aa599b52075
Xserver:	(server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:		(2.7)121bd7ff7cfd9a43fbb61fa56f06ba2d2b55035e
Kernel:       (drm-intel-2.6.29)0aa7e8a61658193f90198d579c5ef8297b45be9b
Bug detailed description:
-------------------------
startx with uxa, then run glean case makeCurrent,X will crash soon.the backtrace from gdb is as below:
#0  0xb7eb3d1b in DRI2GetBuffers (pDraw=0x0, width=0x9754f04,
    height=0x9754f08, attachments=0xbff0c478, count=4, out_count=0xbff0c4a4)
    at dri2.c:139
#1  0xb7e51295 in dri2GetBuffers (driDrawable=0x9754ee0, width=0x9754f04,
    height=0x9754f08, attachments=0xbff0c478, count=4, out_count=0xbff0c4a4,
    loaderPrivate=0x9754e38) at glxdri2.c:363
#2  0xa7a4be10 in intel_update_renderbuffers (context=0x93ce2d0,
    drawable=0x9754ee0) at intel_context.c:235
#3  0xa7a4c261 in intelMakeCurrent (driContextPriv=0x93ce2d0,
    driDrawPriv=0x9754ee0, driReadPriv=0x9754ee0) at intel_context.c:837
#4  0xa7a272be in driBindContext (pcp=0x93ce2d0, pdp=0x9754ee0, prp=0x9754ee0)
    at ../common/dri_util.c:203
#5  0xb7e5113c in __glXDRIcontextForceCurrent (baseContext=0x93d3350)
    at glxdri2.c:202
#6  0xb7e46356 in __glXForceCurrent (cl=0x93cf2d0, tag=1, error=0xbff0c5a8)
    at glxext.c:394
#7  0xb7e43fe7 in DoMakeCurrent (cl=0x93cf2d0, drawId=<value optimized out>,
    readId=0, contextId=0, tag=1) at glxcmds.c:605
#8  0xb7e46876 in __glXDispatch (client=0x93ebec8) at glxext.c:523
#9  0x0808672f in Dispatch () at dispatch.c:437
#10 0x0806c65d in main (argc=2, argv=0xbff0c724, envp=0x9754e38) at main.c:397

Reproduce Steps:
------------------------
1.xinit& (with uxa)
2. run glean case makeCurrent
Comment 1 liuhaien 2009-04-15 00:50:17 UTC
Created attachment 24812 [details]
xorg conf file
Comment 2 martin 2009-04-15 02:40:12 UTC

*** This bug has been marked as a duplicate of bug 20291 ***