Bug 21231 - X1250/RS690: Display connected to HDMI gets no signal
Summary: X1250/RS690: Display connected to HDMI gets no signal
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/radeonhd (show other bugs)
Version: 7.3 (2007.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Luc Verhaegen
QA Contact: Xorg Project Team
Depends on:
Reported: 2009-04-16 10:10 UTC by Philipp Neubeck
Modified: 2011-11-07 15:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

/var/log/Xorg.0.log (91.94 KB, text/plain)
2009-04-16 10:10 UTC, Philipp Neubeck
no flags Details
xrandr --verbose (7.60 KB, application/octet-stream)
2009-04-16 10:10 UTC, Philipp Neubeck
no flags Details
/etc/X11/xorg.conf (2.61 KB, application/octet-stream)
2009-04-16 10:11 UTC, Philipp Neubeck
no flags Details

Description Philipp Neubeck 2009-04-16 10:10:00 UTC
Created attachment 24876 [details]

 Gigabyte GA-MA69GM-S2H with IGP Radeon X1250

lspci output:
 01:05.0 VGA compatible controller: ATI Technologies Inc RS690 [Radeon X1200 Series]

Two displays connected:
Normal LCD Display connected to VGA and is working.
LCD-TV connected to HDMI and does not show anything, i.e. it seems not to get any signal. Yet, the software seems to think, that the display is enabled, because I can move the mouse on the second monitor (of course, i cannot see it there anymore).

MS Windows can use both displays correctly and some version of fglrx worked, too.

I used the following xrandr command:
  xrandr --output DVI-D_1 --crtc 1 --mode 1024x768 --right-of VGA_1

and the attached xorg.conf.
output of xrandr --verbose and the xorg.log are attached.
Comment 1 Philipp Neubeck 2009-04-16 10:10:51 UTC
Created attachment 24877 [details]
xrandr --verbose
Comment 2 Philipp Neubeck 2009-04-16 10:11:43 UTC
Created attachment 24878 [details]
Comment 3 Matthias Hopf 2009-04-17 06:14:10 UTC
  xrandr --output DVI-D_1 --mode 0x50

Maybe your monitor doesn't like 75Hz framerate despite advertising it. Though I doubt that this is the main issue, as you already tried the native 1920x1080 mode.

Also try

  xrandr --output DVI-D_1 --set _Coherent 1

Another idea would be to try

  Option "UseAtomBIOS"

in xorg.conf.
Comment 4 Philipp Neubeck 2009-04-19 06:09:38 UTC
# xrandr --output DVI-D_1 --mode 0x50
xrandr: cannot find mode 0x50

Setting Coherent and UseAtomBIOS both have no visible effect.
In the meantime I gave a try to the radeon driver and shows output on both displays without any tweaking.
Comment 5 Jeremy Huddleston Sequoia 2011-10-16 15:57:37 UTC
Does this issue occur with the preferred ati driver (xf86-vide-ati)?  If so, please move this to the Driver/Radeon component.  

Development of radeonhd has pretty much halted and development focus is on the ati driver.  Please see http://www.x.org/wiki/radeonhd

If the issue does not exist in the ati driver (or if there is no response to this message), this bug will be closed as WONTFIX unless someone contributes a patch.
Comment 6 Jeremy Huddleston Sequoia 2011-11-07 15:39:12 UTC
Closing due to lack of response.  Please reopen and move to the Driver/Radeon 
component if this issue persists with xf86-video-ati

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.