Bug 21352 - [945GM] Problem with virtual resolution in xorg 1.5 (with DRI disabled)
[945GM] Problem with virtual resolution in xorg 1.5 (with DRI disabled)
Status: RESOLVED DUPLICATE of bug 19578
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
x86 (IA32) Linux (All)
: medium normal
Assigned To: Gordon Jin
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 03:52 UTC by waldauf
Modified: 2009-04-27 00:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
My xorg.conf (2.65 KB, application/octet-stream)
2009-04-23 03:52 UTC, waldauf
no flags Details
Xorg.0.log (21.62 KB, application/octet-stream)
2009-04-24 00:29 UTC, waldauf
no flags Details
dmesg (33.40 KB, application/octet-stream)
2009-04-24 01:04 UTC, waldauf
no flags Details
Xorg.0.log with DebugMode (48.59 KB, application/octet-stream)
2009-04-24 01:08 UTC, waldauf
no flags Details
Xorg.0.log with DebugMode and Virtual line (190.81 KB, application/octet-stream)
2009-04-25 04:49 UTC, waldauf
no flags Details
Xorg.0.log with Virtual line and AccelMethod=UXA (57.08 KB, application/octet-stream)
2009-04-25 04:55 UTC, waldauf
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description waldauf 2009-04-23 03:52:12 UTC
Created attachment 25062 [details]
My xorg.conf

hi,

after upgrade to xorg 1.5 I need connect external monitor to my laptop. So I set up virtual resolution in xorg.conf to "3200 1080". But now i cannot switch to console (ctrl+alt+fX) because if I want return back to X I see only blank screen. I have to restart X (ctrl+alt+backspace) and then it works.

I cannot run any movie (in mplayer, vlc) too. If I run any movie my screen will be grain (black and grey) and I have to turn off (via power button) laptop. 

This all disappear if I coment line in xorg.conf contains "Virtual 3200 1080".
Comment 1 Gordon Jin 2009-04-23 06:04:21 UTC
What's the intel driver version? It will be good if you could try 2.7.0, which fixes a similar issue.

Please refer to http://intellinuxgraphics.org/how_to_report_bug.html and attach Xorg.0.log.
Comment 2 waldauf 2009-04-23 06:24:51 UTC
(In reply to comment #1)
> What's the intel driver version? It will be good if you could try 2.7.0, which
> fixes a similar issue.

In my Gentoo is latest version x11-drivers/xf86-video-intel-2.6.3-r1.
 
> Please refer to http://intellinuxgraphics.org/how_to_report_bug.html and attach
> Xorg.0.log.
> 

Ok, I refer this problem to http://intellinuxgraphics.org/how_to_report_bug.html.

Thanks.
Comment 3 Gordon Jin 2009-04-23 18:05:47 UTC
(In reply to comment #2)
> > Please refer to http://intellinuxgraphics.org/how_to_report_bug.html and attach
> > Xorg.0.log.
> > 
> 
> Ok, I refer this problem to
> http://intellinuxgraphics.org/how_to_report_bug.html.

I'm waiting for your log.
Comment 4 waldauf 2009-04-24 00:29:23 UTC
Created attachment 25083 [details]
Xorg.0.log

There is my Xorg.0.log.
Comment 5 waldauf 2009-04-24 01:03:41 UTC
Driver 2.7.0 I cannot use because isn't in Gentoo repository.

> 
> Please refer to http://intellinuxgraphics.org/how_to_report_bug.html and attach
> Xorg.0.log.
> 

Laptop:
FS Amilo Pro V32205

Chipset:
VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Drivers:
* x11-base/xorg-server-1.5.3-r5  USE="hal kdrive nptl xorg -3dfx -debug -dmx -ipv6 -minimal -sdl -tslib" INPUT_DEVICES="evdev keyboard mouse synaptics -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -tek4957 -tslib -ur98 -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="intel -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nv -nvidia -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -vesa -via -virtualbox -vmware -voodoo -xgi"

* x11-libs/libdrm-2.4.5  USE="-debug"

* media-libs/mesa-7.3-r1  USE="nptl -debug -doc -motif -pic -xcb"  VIDEO_CARDS="intel -mach64 -mga -none -r128 -radeon -s3virge -savage -sis (-sunffb) -tdfx -trident -via"

* x11-proto/dri2proto-1.99.3
* x11-proto/xf86driproto-2.0.4


System architecture and kernel:
Gentoo linux
vanilla kernel - 2.6.29.1 
architecture i686

Display connector - DVI


Comment 6 waldauf 2009-04-24 01:04:54 UTC
Created attachment 25086 [details]
dmesg
Comment 7 waldauf 2009-04-24 01:08:52 UTC
Created attachment 25087 [details]
Xorg.0.log with DebugMode
Comment 8 waldauf 2009-04-24 01:12:15 UTC
I want to tell that new Xorg is quite slow. I don't remember my FPS in old Xorg (1.3.*) but there is about 57 FPS. I see it by 3D effect (in fluxbox I use 3ddesktop application to switch between desktops and it is too slow).

Comment 9 waldauf 2009-04-25 01:35:16 UTC
(In reply to comment #8)
> I want to tell that new Xorg is quite slow. I don't remember my FPS in old Xorg
> (1.3.*) but there is about 57 FPS. I see it by 3D effect (in fluxbox I use
> 3ddesktop application to switch between desktops and it is too slow).
> 

I found that 57 FPS is quite normal so I'm sorry. 
Comment 10 Gordon Jin 2009-04-25 03:02:10 UTC
(In reply to comment #4)
> Created an attachment (id=25083) [details]
> Xorg.0.log
> 
> There is my Xorg.0.log.
> 

Does all your reported problems happen only when you set virtual "3200 1080" in xorg.conf? But your Xorg.0.log doesn't show Virtual set.
Comment 11 waldauf 2009-04-25 03:07:00 UTC
(In reply to comment #10)
> (In reply to comment #4)
> > Created an attachment (id=25083) [details] [details]
> > Xorg.0.log
> > 
> > There is my Xorg.0.log.
> > 
> 
> Does all your reported problems happen only when you set virtual "3200 1080" in
> xorg.conf? But your Xorg.0.log doesn't show Virtual set.
> 

Sorry, I have commented line with virtual resolution. I create new Xorg.0.log and paste it here (in 1 hour, I cannot restart X now).
Comment 12 waldauf 2009-04-25 04:49:47 UTC
Created attachment 25132 [details]
Xorg.0.log with DebugMode and Virtual line

There is required Xorg.0.log. Now I have connect external LCD (1920x1080). 

I have to tell that if I have open firefox and I want to scroll down (any web page) it's horribly slow. With this it is impossible work.
Comment 13 waldauf 2009-04-25 04:55:33 UTC
Created attachment 25134 [details]
Xorg.0.log with Virtual line and AccelMethod=UXA


If I add to Section Device this options:
Option      "DRI"           "true"
Option      "AccelMethod"   "UXA"

Than I cannot run XDM. XDM is starting and my LCD on laptop is blinking. After a ew minutes it stops and I see console.
Comment 14 Gordon Jin 2009-04-27 00:01:49 UTC
So your chipset is 945, that means you lose DRI if setting Virtual > 2048 pixels. (bug#10479, probably won't be fixed in near future)

With DRI disabled, there are some known issues:
bug#19578: VT->X broken.
bug#21060: playing video broken in 2.6.x driver, fixed in 2.7.0.
expected slow.

Does this explain the problems you are seeing?

Before bug#10479 resolved, maybe you can use the workaround for layout the dual monitors as top-down so it fits within 2048x2048.

And if you want to use UXA, better use xserver 1.6.x.

*** This bug has been marked as a duplicate of bug 19578 ***