Bug 21374 - [Mobility FireGL 9000] cs_gem_write_reloc: Assertion `bo->space_accounted` failed.
Summary: [Mobility FireGL 9000] cs_gem_write_reloc: Assertion `bo->space_accounted` f...
Status: NEW
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r200 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
Depends on:
Reported: 2009-04-24 04:12 UTC by Nikolay Vladimirov
Modified: 2010-10-12 01:20 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

dmesg (36.77 KB, text/plain)
2009-04-24 04:12 UTC, Nikolay Vladimirov
xorg log (50.39 KB, text/plain)
2009-04-24 04:14 UTC, Nikolay Vladimirov
Experimenatal patch to fix space validation assertion (40.23 KB, patch)
2009-08-14 06:38 UTC, Pauli
Details | Splinter Review

Description Nikolay Vladimirov 2009-04-24 04:12:50 UTC
Created attachment 25095 [details]

Description of problem:
Using clean fedora 11 latest rawhide network install. No manual modification.
just opened up a terminal and ran glxgears.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run glxgears

Actual results:
glxgears exits with:
glxgears: radeon_cs_gem.c:121: cs_gem_write_reloc: Assertion
`bo->space_accounted` failed.

Expected results:
Normal glxgears run.

Additional info:
there are some radeon related messages from the kernel. Attaching dmesg and
Xorg.0.log. No xorg.conf.
Comment 1 Nikolay Vladimirov 2009-04-24 04:14:00 UTC
Created attachment 25096 [details]
xorg log
Comment 2 Alexander Hunziker 2009-08-13 03:17:33 UTC
I have the media center software "Moovida" fail on startup with the same error message:

python: ../../../libdrm/radeon/radeon_cs_gem.c:121: cs_gem_write_reloc: Assertion `bo->space_accounted' failed.
Aborted (core dumped)

This is on Ubuntu Karmic with the new radeon-rewrite stack and DRI2.
Comment 3 Pauli 2009-08-13 04:54:19 UTC
Can you try to get backtrace?

easy way to do it is to enable core dumps and then analysing dump with gdb:

ulimit -c unlimited
gdb --core=core glxgears
bt full
Comment 4 Alexander Hunziker 2009-08-14 02:36:06 UTC
Not sure how helpful this will be, as there are many missing symbol names. Anyway, there you go:

Core was generated by `/usr/bin/python /usr/bin/moovida'.
Program terminated with signal 6, Aborted.
#0  0xb7f84422 in __kernel_vsyscall ()
(gdb) bt full
#0  0xb7f84422 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb7dde4f1 in ?? ()
No symbol table info available.
#2  0xb7f07ff4 in ?? ()
No symbol table info available.
#3  0xb5d3be38 in ?? ()
No symbol table info available.
#4  0xb5d3be40 in ?? ()
No symbol table info available.
#5  0xb7de1952 in ?? ()
No symbol table info available.
#6  0x00000006 in ?? ()
No symbol table info available.
#7  0xb5d3bdb8 in ?? ()
No symbol table info available.
#8  0x00000000 in ?? ()
No symbol table info available.
Comment 5 Pauli 2009-08-14 06:38:03 UTC
Created attachment 28624 [details] [review]
Experimenatal patch to fix space validation assertion

You would need to install debug symbols (libgl1-mesa-dri-dbg package for me)

Can you try attached patch if it fixes problem for you?
Comment 6 Alexander Hunziker 2009-08-14 08:28:06 UTC
I tried to get a better stack trace, but failed. I have all mesa and dri debug symbols installed that I could find but there are still no symbol names in the trace.

I notice the patch is against files in the r200 directory. I'm using an R500 GPU (Radeon Mobile X1400) - is the patch still relevant?

I will try to apply the patch, but I'll have to read myself into debian packaging again before I can do that. If someone feels like providing a Karmic package, I won't be mad :-)
Comment 7 Pauli 2009-08-14 09:25:41 UTC
I just looked at original report that told card is r200 so fix is for r200 only. There is no similar patch for r300 yet so you have to wait for a moment.

I guess backtrace problem is because of python. It might help if you installed python debug symbols. Also libdrm2-dbg will show symbols for few last calls.

It would help if you could reproduce same bug with some others program too.
Comment 8 Alexander Hunziker 2009-08-14 09:49:14 UTC
Sorry for not mentioning what hardware I use earlier.

I cannot reproduce the bug in anything else so far. glxgears, neverball, and all GL screensavers work fine.

The patch applied cleanly to a recent git snapshot of MESA. I'll be happy to try it out when there's a patch for the r300 series.
Comment 9 Adam Jackson 2009-08-24 12:32:06 UTC
Mass version move, cvs -> git
Comment 10 Fabio Pedretti 2010-10-12 01:20:37 UTC
This could be fixed in mesa master and 7.9 branch:

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.