Bug 21393 (franzrogar) - [UXA] Blender font and icons are distorted, 3D window screwed
Summary: [UXA] Blender font and icons are distorted, 3D window screwed
Status: RESOLVED DUPLICATE of bug 19174
Alias: franzrogar
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-24 14:00 UTC by Franz Rogar
Modified: 2009-06-05 16:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg config file (1.20 KB, text/plain)
2009-04-24 14:00 UTC, Franz Rogar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franz Rogar 2009-04-24 14:00:43 UTC
Created attachment 25118 [details]
Xorg config file

SYSTEM SPEC
-----------
linux kernel  2.6.30rc3
distribution  Ubuntu 9.04
architecture  x86_64
graphic card  Intel X3100 GMA (GM965/GL960 [8086:2a02] (rev 03)
xserver-xorg  1.6.0
intel driver  2.7.0
mesa          7.4
libdrm2       2.4.9
libdrm-intel1 2.4.9


SOFTWARE TESTED
---------------
blender [1]   2.48a and 2.5-svn

[1] http://www.blender.org


PROBLEMS
-------

Problem 01: "icons" (image next to text) and "text" itself (using "International Font" with NO "texture" mode) are shown missplaced and distorted.
Image: http://img207.imageshack.us/img207/3355/pantallazokmi.png

It was working as expected in Ubuntu 8.10 with default instalation (in EXA mode).


Problem 02: 3D Window is deformed. There're 2 rectangles that aren't updated at all. Also, when you render the image, the default scene is not a cube but a rectangular box.
Image: same as before. You can see in 3D Window 2 cubes... well, there're not. A rectangle up and a rectangle down should be refreshed to show only a cube (default scene).

It was working as expected in Ubuntu 8.10 with default instalation (in EXA mode).


Attached xorg.conf.

Thanks in advance.
Comment 1 Gordon Jin 2009-04-28 18:31:40 UTC
likely related to the DRI2 frontbuffer rendering issue.
Comment 2 Franz Rogar 2009-04-29 20:18:57 UTC
Thanks for reply.

Do you refer to [1] bug #19174? Seems so 'cause I tried to run it in EXA mode (same spec as before) and the issues remained.

Just one update: the "text" issue with NO "texture mode" in Blender 2.5-svn branch was fixed indirectly with this commit [2] though 2.4x branch will have it "always" (2.5 is a UI refactoring and the commit can't be backported).

But the other two bugs (3D window and icons) seems to be affected by #19174.

Thank you very much for your work :-D


[1] http://bugs.freedesktop.org/show_bug.cgi?id=19174
[2] http://lists.blender.org/pipermail/bf-blender-cvs/2009-April/019130.html
Comment 3 Gordon Jin 2009-06-05 16:32:11 UTC
Please reopen if the fix for bug#19174 doesn't work for you.

*** This bug has been marked as a duplicate of bug 19174 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.