Bug 2152 - System freeze with DRI since Kernel 2.6.9
System freeze with DRI since Kernel 2.6.9
Status: RESOLVED INVALID
Product: DRI
Classification: Unclassified
Component: DRM/other
XOrg 6.7.0
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-26 03:24 UTC by René Rietz
Modified: 2004-12-25 21:03 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Rietz 2004-12-26 03:24:54 UTC
After I switched to Kernel 2.6.9 I realized a number of random freezes.
Yesterday I compiled the newer Kernel 2.6.10 and run glxgears. The system was
frozen after 15-20 s. I rebootet and run glxgears again (same result). After a
look in the Kernel's Changelog I realized a change of many DRM-Components
(Kernel 2.6.9).
Kernel 2.6.8.1 works without any issues.

Steps to reproduce:
1. Compile Kernel 2.6.9 or 2.6.10
2. Run glxgears
Result:
The system freezes after a couple of seconds.
Comment 1 Roland Scheidegger 2004-12-26 06:21:17 UTC
It might be helpful to know what graphic card you're using...
Comment 2 René Rietz 2004-12-26 08:38:28 UTC
Sorry, I forgot this. I'm using the ATI Binary Drivers (flglrx) with my Radeon
9600 pro. The problem seems to be driver and Card-independent:

http://forums.gentoo.org/viewtopic.php?t=215629&highlight=crash&sid=8a6167dfc0ee1b44d0eeae5ec28c3df4

http://forums.gentoo.org/viewtopic.php?t=198023&postdays=0&postorder=asc&start=0
Comment 3 Roland Scheidegger 2004-12-26 16:03:28 UTC
If you're using fglrx, you don't use any drm components of the kernel at all -
make sure you don't have them compiled in, since the radeon module cannot be
loaded at the same time as the fglrx drm module (you should certainly be able to
have it compiled as a module, it just shouldn't get loaded).
Glancing over that gentoo thread, I fail to see if/how that could be related.
Some of the people there are even using nvidia cards, and their code sure as
hell doesn't use drm kernel code (ati shares at least the drm design principles
afaik, but nvidia does not).
If indeed something in newer kernels causes problems with ati or nvidia drivers,
you'd need to complain to them.