Bug 21523 - Grey border around images
Grey border around images
Status: RESOLVED DUPLICATE of bug 17933
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
Other All
: low normal
Assigned To: Carl Worth
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 08:36 UTC by Michael Thoron
Modified: 2010-06-24 01:30 UTC (History)
2 users (show)

See Also:


Attachments
google mail image (13.39 KB, image/png)
2009-05-02 08:36 UTC, Michael Thoron
no flags Details
image open in firefox for test (67.35 KB, image/jpeg)
2009-05-11 07:32 UTC, Michael Thoron
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Thoron 2009-05-02 08:36:36 UTC
Created attachment 25371 [details]
google mail image

FireFox (version: 3.5 beta 4) displays grey border arround some images, like the html view in google mail, company image.

This work using xaa with same FireFox version without border.
I run on i915, and fedora 11 preview release with driver-2.7, kms is enabled.
Comment 1 Michael Thoron 2009-05-11 07:32:35 UTC
Created attachment 25729 [details]
image open in firefox for test

Open in FireFox, you see grey border top and left for image size fit screen properties.  On clicking (image original size) everything is ok.

Fav-Icon (left of address) also have gray border.
Comment 2 Y-H Chen 2009-07-06 21:58:05 UTC
I can confirm this bug. See also:
-- https://bugzilla.mozilla.org/show_bug.cgi?id=490799
-- https://bugzilla.mozilla.org/show_bug.cgi?id=490997
-- https://bugzilla.mozilla.org/show_bug.cgi?id=497813
-- https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/274575
My system specifications are as follows: Intel 945 GM, i686, kernel 2.6.29.5-191, Fedora 11, Thinkpad T60. Let me know if you'd like further information.
Comment 3 Clemens Eisserer 2009-08-01 11:43:00 UTC
left a comment in the other bug-reports pointing to this report.
Comment 4 Denny Crane 2009-09-06 11:47:17 UTC
Same problem here. I have observed top and left borders on images and have confirmed that it happens when the image is scaled. I believe I have seen the borders in colors other than grey, too. I am using Fedora 11 and Intel graphics.
Comment 5 Y-H Chen 2009-09-28 22:06:48 UTC
I've tried Option "NoAccel" "true" and Option "AccelMethod" "XAA" in the "Device" section of xorg.conf. Neither modification resolves the problem for me. 
Comment 6 Chris Wilson 2009-11-10 07:36:42 UTC
This looks like the texture sampling bug coupled with bug 17933.

The first part I believe to be fixed with
commit 14109abf285866ad4cd99d0cd16b0954a0a73a62
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Nov 10 11:17:23 2009 +0000

    i915: Fix texture sampling coordinates.
    
    RENDER specifies that texels should sampled from the pixel centre. This
    corrects a number of failures in the cairo test suite and a few
    off-by-one bug reports.
    
      Grey border around images
      https://bugs.freedesktop.org/show_bug.cgi?id=21523
    
    Note that the earlier attempt to fix this was subverted by the buggy use
    of 1x1R textures for solid sources -- which caused the majority of text
    to disappear.
    
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>

The second requires a little more fixes spread around the packages a little debate... But for the time being I believe this bug reduces to be a dup of 17933.

*** This bug has been marked as a duplicate of bug 17933 ***
Comment 7 Y-H Chen 2010-06-23 19:37:09 UTC
The problem is persisting with xorg-x11-drv-intel-2.11.0-4 and firefox-3.6.3-4 on a Fedora 13 system.
Comment 8 Chris Wilson 2010-06-24 01:30:18 UTC
(In reply to comment #7)
> The problem is persisting with xorg-x11-drv-intel-2.11.0-4 and firefox-3.6.3-4
> on a Fedora 13 system.

Yes, that patch was found to cause a few problems and so I had to revert before 2.11. However, 2.12 fixes it for sure! :)


commit dc402334f4e9b0de624bc89cd77eae4ec7cf1708
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Jun 1 23:03:19 2010 +0100

    i915: Centre sampling.
    
    Use centre sampling of textures to match pixman, and remove numerous
    off-by-one and visual artefacts when rendering. The classic example for
    this is cairo/text/xcomposite-projection where the edge of the rotated
    rectangle is jaggy due to the incorrect sample position.
    
    Fixes:
    
      Bug 16917  - [i915] Blur on y-axis also when only x-axis is scaled
                   billiear
      https://bugs.freedesktop.org/show_bug.cgi?id=16917
    
    And about 15 tests from the Cairo test suite.