Bug 21574 - [G41] DRM_I915_ENTERVT failed (SIGSEGV) (UXA bug)
[G41] DRM_I915_ENTERVT failed (SIGSEGV) (UXA bug)
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
x86-64 (AMD64) Linux (All)
: high critical
Assigned To: Ian Romanick
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-05 13:30 UTC by Bryce Harrington
Modified: 2009-07-10 14:41 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (13.83 KB, text/plain)
2009-05-05 13:31 UTC, Bryce Harrington
no flags Details
XorgConf.txt (1.11 KB, text/plain)
2009-05-05 13:31 UTC, Bryce Harrington
no flags Details
dmesg (46.24 KB, text/plain)
2009-05-05 23:27 UTC, Tommaso Schiavinotto
no flags Details
Xorg.0.log immediately after crash (16.35 KB, text/x-log)
2009-06-14 18:35 UTC, Lavy Libman
no flags Details
kern.log immediately after crash (clean reboot) (628.40 KB, text/x-log)
2009-06-14 18:37 UTC, Lavy Libman
no flags Details
lspci -v output (7.69 KB, application/octet-stream)
2009-06-14 18:37 UTC, Lavy Libman
no flags Details
Xorg.0.log (49.33 KB, application/octet-stream)
2009-06-23 02:46 UTC, Adam Kuller
no flags Details
xorg.conf (1.29 KB, application/octet-stream)
2009-06-23 02:46 UTC, Adam Kuller
no flags Details
lspci -v (7.36 KB, application/octet-stream)
2009-06-23 02:47 UTC, Adam Kuller
no flags Details
glxinfo (9.13 KB, application/octet-stream)
2009-06-23 02:47 UTC, Adam Kuller
no flags Details
dmesg (51.29 KB, application/octet-stream)
2009-06-23 02:47 UTC, Adam Kuller
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2009-05-05 13:30:46 UTC
Forwarding this bug from a ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/363305

[Problem]
With UXA enabled, a segfault occurs with this error:
DRM_I915_ENTERVT failed: Unknown error 18446744073709551604

Issue is seen in both 2.6.3 and 2.7.0 (from x-updates).

 distro:             Ubuntu
 architecture:       x86_64
 kernel:             2.6.28-11-generic
 xserver-xorg:       1:7.4~5ubuntu18
 mesa:               7.4-0ubuntu2
 libdrm:             2.4.5-0ubuntu4
 -intel:             2:2.6.3-0ubuntu9
 -ati:               1:6.12.1-0ubuntu2
 ProcVersion: Linux version 2.6.28-11-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 4 Series Chipset DRAM Controller [8086:2e20] (rev 03)
     Subsystem: ASRock Incorporation Device [1849:2e20]
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e22] (rev 03)
     Subsystem: ASRock Incorporation Device [1849:2e22]
Comment 1 Bryce Harrington 2009-05-05 13:31:18 UTC
Created attachment 25493 [details]
Xorg.0.log
Comment 2 Bryce Harrington 2009-05-05 13:31:51 UTC
Created attachment 25494 [details]
XorgConf.txt
Comment 3 Bryce Harrington 2009-05-05 13:33:53 UTC
Backtrace:
0: /usr/X11R6/bin/X(xorg_backtrace+0x26) [0x4f1b66]
1: /usr/X11R6/bin/X(xf86SigHandler+0x41) [0x485a61]
2: /lib/libc.so.6 [0x7f4f7e190040]
3: /usr/lib/xorg/modules/drivers//intel_drv.so(I830EmitFlush+0x8f) [0x7f4f7c3ca0cf]
4: /usr/lib/xorg/modules/drivers//intel_drv.so(I830Sync+0x54) [0x7f4f7c3ca4c4]
5: /usr/lib/xorg/modules/drivers//intel_drv.so [0x7f4f7c3d78aa]
6: /usr/X11R6/bin/X(SigAbortDDX+0x8d) [0x46d71d]
7: /usr/X11R6/bin/X(AbortServer+0x1d) [0x4fb33d]
8: /usr/X11R6/bin/X(LogVMessageVerb+0) [0x4fba30]
9: /usr/lib/xorg/modules/drivers//intel_drv.so [0x7f4f7c3d8622]
10: /usr/lib/xorg/modules/drivers//intel_drv.so [0x7f4f7c3d9c4c]
11: /usr/X11R6/bin/X(AddScreen+0x1c6) [0x4334c6]
12: /usr/X11R6/bin/X(InitOutput+0x241) [0x46ee21]
13: /usr/X11R6/bin/X(main+0x20e) [0x433bde]
14: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f4f7e17b5a6]
15: /usr/X11R6/bin/X [0x433219]
Saw signal 11. Server aborting.
Comment 4 Gordon Jin 2009-05-05 19:11:28 UTC
what's the reproducible step? Could you attach dmesg as well?
Comment 5 Tommaso Schiavinotto 2009-05-05 23:13:12 UTC
Using intel driver with uxa is enough to reproduce the bug.

I will attach the dmesg output as well.
Comment 6 Tommaso Schiavinotto 2009-05-05 23:27:55 UTC
Created attachment 25532 [details]
dmesg

This is the dmesg I found in /var/log I could not run the dmesg command after the problem because I get a blank screen, the monitor goes in stand by mode and I have to reset from hardware to reboot.
Comment 7 Gordon Jin 2009-05-05 23:42:44 UTC
(In reply to comment #5)
> Using intel driver with uxa is enough to reproduce the bug.

Do you mean this happens immediately after X started, not requiring any other operations?
Comment 8 Jesse Barnes 2009-05-11 11:21:25 UTC
Adjusting severity: crashes & hangs should be marked critical.
Comment 9 Bryce Harrington 2009-05-29 05:43:22 UTC
Tommaso, that dmesg doesn't have correct info for your card.  You should be able to run dmesg after sshing into your machine.  If you can't ssh into it, you could try switching to vt2, running "sleep 15 ; dmesg > dmesg.txt" or something, and switching back to vt1 to get it.

Fwiw, the error being returned seems to be an "out of memory" error, but that's sort of strange to happen at boot.
Comment 10 Jarek Kuboš 2009-06-03 12:28:42 UTC
I have same issue, my dmesg says:

[103629.818053] [drm] Initialized drm 1.1.0 20060810
[103629.901954] pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[103629.901963] pci 0000:00:02.0: setting latency timer to 64
[103629.928071] mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
[103629.928077] [drm] MTRR allocation failed.  Graphics performance may suffer.
[103629.928105]   alloc irq_desc for 27 on cpu 0 node 0
[103629.928110]   alloc kstat_irqs on cpu 0 node 0
[103629.928126] pci 0000:00:02.0: irq 27 for MSI/MSI-X
[103629.928158] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[103630.213560] [drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[103630.213567] [drm:i915_gem_object_pin] *ERROR* Failure to bind: -12
Comment 11 Lavy Libman 2009-06-14 18:35:54 UTC
Created attachment 26785 [details]
Xorg.0.log immediately after crash
Comment 12 Lavy Libman 2009-06-14 18:37:00 UTC
Created attachment 26786 [details]
kern.log immediately after crash (clean reboot)
Comment 13 Lavy Libman 2009-06-14 18:37:19 UTC
Created attachment 26787 [details]
lspci -v output
Comment 14 Lavy Libman 2009-06-14 18:48:19 UTC
Just a "me too" with a couple of additional observations
(see my log files and "lspci -v" output attached above):

- All of us reporting this bug seem to share the ASRock Incorporation Device 2e20, 2e22 (apparently the ASRock G43Twins-FullHD board). I've searched long and hard for any reports of the same crash on other hardware, but couldn't find any.

- The crash has been absolutely 100% consistent on UXA since driver 2.6 (Ubuntu Jaunty, and I've been applying every driver and kernel update from xorg-edgers since).

- The system worked fine under Intrepid (Ubuntu 8.10, driver 2.4+kernel 2.6.27) or with 2.6 or 2.7 driver with 2.6.27 kernel (no GEM).

- If this helps, on any kernel >=2.6.28 I tried, driver 2.6 or 2.7 using EXA causes a "failed to initialize kernel memory manager" (see the report in https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/380986, with the same hardware), and, again, this is 100% consistent.

All in all, looks like some sort of memory allocation/management issue with this particular chipset.
Will be glad to provide any further information / try any suggestions.
Comment 15 Adam Kuller 2009-06-15 08:16:51 UTC
Same crash by me too immediately after X started.
I have an ASROCK G41M-LE motherboard with integrated Intel G41 X4500 (8086:2e32 windows7 based OS shows 8086:2e33) gma.

Tested kernels: 2.6.26 i386 and 2.6.30 i386 and amd64
Tested drivers: 2.3.2, 2.7.1, 2.7.99.901-2
Tested distro: Ubuntu9.04, Ubuntu 9.10, Debian 5.0

The Xorg.0.log result is (@amd64):
Fatal server error:
DRM_I915_ENTERVT failed: Unknown error 18446744073709551604

The Xorg.0.log result is (@i386):
Fatal server error:
DRM_I915_ENTERVT failed: Unknown error 4294967284

[lspci -v]
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
	Subsystem: ASRock Incorporation Device 2e30
	Flags: bus master, fast devsel, latency 0
	Capabilities: [e0] Vendor Specific Information <?>
	Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
	Subsystem: ASRock Incorporation Device 2e32
	Flags: bus master, fast devsel, latency 0, IRQ 27
	Memory at fe400000 (64-bit, non-prefetchable) [size=4M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at cc00 [size=8]
	Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCIe advanced features <?>

00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
	Subsystem: ASRock Incorporation Device 2e32
	Flags: bus master, fast devsel, latency 0
	Memory at fe900000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 2
Comment 16 Jarek Kuboš 2009-06-15 09:25:21 UTC
I have Gigabyte GA-EG41MF-S2H board
Comment 17 svrmarty@gmx.net 2009-06-16 15:25:37 UTC
same here


Backtrace:
0: X(xorg_backtrace+0x38) [0x819baf8]

Fatal server error:
Caught signal 11.  Server aborting


dmesg:
[drm] LVDS-8: set mode 1024x768 24
i2c-adapter i2c-1: unable to read EDID block.
i915 0000:00:02.0: LVDS-1: no EDID data
i2c-adapter i2c-1: sendbytes: NAK bailout.
i2c-adapter i2c-1: unable to read EDID block.
i915 0000:00:02.0: LVDS-1: no EDID data
[drm] DAC-6: set mode 800x600 3c
[drm] LVDS-8: set mode 800x600 3d
Comment 18 Adam Kuller 2009-06-23 02:45:14 UTC
I think, this is not an UXA bug. The problem is not depend from AccelMethod(EXA,UXA).

I posted a new report with latest intel and drm driver(git). The error has not changed, G41 X4500 GMA is still useless on linux.

Xorg with Option "ModeDebug" "yes".
Comment 19 Adam Kuller 2009-06-23 02:46:16 UTC
Created attachment 27039 [details]
Xorg.0.log
Comment 20 Adam Kuller 2009-06-23 02:46:46 UTC
Created attachment 27040 [details]
xorg.conf
Comment 21 Adam Kuller 2009-06-23 02:47:06 UTC
Created attachment 27041 [details]
lspci -v
Comment 22 Adam Kuller 2009-06-23 02:47:24 UTC
Created attachment 27042 [details]
glxinfo
Comment 23 Adam Kuller 2009-06-23 02:47:41 UTC
Created attachment 27043 [details]
dmesg
Comment 24 Adam Kuller 2009-06-26 16:12:06 UTC
(My) Problem solved!

I set the Shared Memory size to 128MB in BIOS, and intel driver works!(compiz too)

When the Shared Memory set to 256MB intel driver crash at startup.
The Xorg.0.log result is (@amd64):
Fatal server error:
DRM_I915_ENTERVT failed: Unknown error 18446744073709551604

The Xorg.0.log result is (@i386):
Fatal server error:
DRM_I915_ENTERVT failed: Unknown error 4294967284
Comment 25 Eric Anholt 2009-07-02 11:13:31 UTC
Proposed patch:
http://lists.freedesktop.org/archives/intel-gfx/2009-July/003180.html
Comment 26 Eric Anholt 2009-07-10 14:41:50 UTC
In the absence of any response, it's now queued:

commit 2a34f5e6b61c7e8f3b6f25847bcda88511b0ead4
Author: Eric Anholt <eric@anholt.net>
Date:   Thu Jul 2 09:30:50 2009 -0700

    drm/i915: Disable GEM when a broken video BIOS takes up the whole aperture.