Bug 21577 - [i965gm] Blender is unusable with UXA (UXA bug)
Summary: [i965gm] Blender is unusable with UXA (UXA bug)
Status: RESOLVED DUPLICATE of bug 19174
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Gordon Jin
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-05 14:10 UTC by Bryce Harrington
Modified: 2009-05-05 19:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot-Blender.png (29.87 KB, image/png)
2009-05-05 14:11 UTC, Bryce Harrington
no flags Details
xorg.conf (1.41 KB, application/octet-stream)
2009-05-05 14:11 UTC, Bryce Harrington
no flags Details
Xorg.0.log (31.70 KB, text/x-log)
2009-05-05 14:12 UTC, Bryce Harrington
no flags Details
Screenshot.png (173.58 KB, image/png)
2009-05-05 14:12 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2009-05-05 14:10:41 UTC
Forwarding this bug report from a ubuntu reporter:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/353763

[Problem]
On Jaunty 64 bit with Intel GM965 and UXA enabled Blender is not usable because all GUI elements change their position on hovering. This does not happen with EXA.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
     Subsystem: Dell Device [1028:01f9]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)
     Subsystem: Dell Device [1028:01f9]

glxinfo | grep GLX_EXT_texture_from_pixmap
   GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_texture_from_pixmap,
   GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
   GLX_EXT_texture_from_pixmap

All the pop-ups and menus seem to be absolute positioned from the top
left of the screen and not from the top left of the blender window
content. Have a look at the screenshot. I tried to visualizing it. All
red rectangles have the same size.

I still have exactly the same problems after installing
* libdrm2_2.4.9-1ubuntu1~xup~1_amd64.deb
* libdrm-intel1_2.4.9-1ubuntu1~xup~1_amd64.deb
* xserver-xorg-video-intel_2.7.0-1ubuntu1~xup~1_amd64.deb
Comment 1 Bryce Harrington 2009-05-05 14:11:28 UTC
Created attachment 25505 [details]
Screenshot-Blender.png
Comment 2 Bryce Harrington 2009-05-05 14:11:50 UTC
Created attachment 25506 [details]
xorg.conf
Comment 3 Bryce Harrington 2009-05-05 14:12:14 UTC
Created attachment 25507 [details]
Xorg.0.log
Comment 4 Bryce Harrington 2009-05-05 14:12:59 UTC
Created attachment 25508 [details]
Screenshot.png
Comment 5 Gordon Jin 2009-05-05 19:07:23 UTC

*** This bug has been marked as a duplicate of bug 19174 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.