Bug 21776 - [radeon-rewrite] compiz crashes Xorg
Summary: [radeon-rewrite] compiz crashes Xorg
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-17 03:28 UTC by Tormod Volden
Modified: 2009-05-18 10:49 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (46.08 KB, text/plain)
2009-05-17 03:29 UTC, Tormod Volden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tormod Volden 2009-05-17 03:28:42 UTC
After the last days' updates from git, I can not start compiz any longer.

I tried to run gdb on Xorg and it dies with:
Program exited with code 0352.

dmesg:
[47841.913989] [drm:r300_do_cp_cmdbuf] *ERROR* bad cmd_type 0 at f65c5b08
 
/var/log/gdm/:0.log.1:
CS section size missmatch start at (r300_cmdbuf.c,emit_tex_offsets,182) 4 vs 2
CS section end at (r300_cmdbuf.c,emit_tex_offsets,202)
drmRadeonCmdBuffer: -22
Comment 1 Tormod Volden 2009-05-17 03:29:29 UTC
Created attachment 25928 [details]
Xorg.0.log
Comment 2 Maciej Cencora 2009-05-17 04:52:22 UTC
The problem is already known and exists only in DRI1. Please revert 76a64958a4ca38ec27b63a909979c493c507b952 as a temporary workaround.
Comment 3 Jerome Glisse 2009-05-18 01:49:39 UTC
Please confirm that commit d039cf4574893e480d33f286e3526c6805d919fd fix the issue
Comment 4 Tormod Volden 2009-05-18 10:49:04 UTC
Yes, this seems to be fixed. Thanks!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.