Bug 2181 - kbd driver doesn't handle lock state correctly on VT switch
Summary: kbd driver doesn't handle lock state correctly on VT switch
Status: RESOLVED DUPLICATE of bug 1530
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 890
  Show dependency treegraph
 
Reported: 2004-12-31 02:00 UTC by ismail ( cartman ) donmez
Modified: 2013-03-15 14:48 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ismail ( cartman ) donmez 2004-12-31 02:00:01 UTC
Firstly my X.org version: 
 
X Window System Version 6.8.1.99 (Ubuntu 6.8.1-1ubuntu8 20041219153722 
root@terranova.warthogs.hbd.com) 
Release Date: 2 October 2004 + 6.8.x branch CVS 
 
Now the problem: 
 
Turn on numlock key while in X (so that you can use numpad). Now switch to a 
tty like tty6 with CTRL-ALT-F6. Note that Numlock is still on but it should be 
off because I didn't enable numlock in tty6. Now go back to X with 
CTRL-ALT-F7. Now notice that numlock is now disabled(!). And if you try to 
enable it you hate to press numlock key _twice_.
Comment 1 ismail ( cartman ) donmez 2004-12-31 02:00:32 UTC
Also worth noting this bug is reproducable with X.org 6.8.0 . 
Comment 2 ismail ( cartman ) donmez 2005-01-01 08:20:16 UTC
Note that when you go back to X from vt6 (or any vt) you can still use 
numpad.So although numlock led is off, numpad works. 
 
Comment 3 ismail ( cartman ) donmez 2005-03-25 10:22:52 UTC
Still same problem in X.org 6.8.2 
Comment 4 ismail ( cartman ) donmez 2005-10-02 22:20:00 UTC
Problem exists in latest CVS still. 
Comment 5 Pavel Janík 2006-01-31 22:43:27 UTC
Duplicate to 1530.

*** This bug has been marked as a duplicate of 1530 ***
Comment 6 Samuel Thibault 2013-03-15 14:48:52 UTC
I'm still having the issue with Xorg 7.7 and linux 3.2. For instance, starting from numlock enabled both on VT1 and in Xorg. Switching to VT1, and then switching back to xorg, the numlock disappears in xorg (although numlock is really enabled). One has to press numlock twice to get the led back on.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.