Bug 21936 - [Ubuntu-9.04]: Overlapping glxgears window with a terminal window results in a corruption
[Ubuntu-9.04]: Overlapping glxgears window with a terminal window results in ...
Status: RESOLVED DUPLICATE of bug 21653
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100
unspecified
x86 (IA32) Linux (All)
: medium major
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 03:55 UTC by Sunil Mekathotti
Modified: 2009-06-05 07:42 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg-log (60.01 KB, text/plain)
2009-05-26 03:57 UTC, Sunil Mekathotti
Details
xorg.conf (1.49 KB, text/plain)
2009-05-26 03:58 UTC, Sunil Mekathotti
Details
glxgears launched (163.90 KB, image/pjpeg)
2009-05-26 04:03 UTC, Sunil Mekathotti
Details
glxgears overlapped with a terminal window (135.55 KB, image/pjpeg)
2009-05-26 04:05 UTC, Sunil Mekathotti
Details
the terminal window still got a black patch that that doesn't refresh (175.87 KB, image/pjpeg)
2009-05-26 04:07 UTC, Sunil Mekathotti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sunil Mekathotti 2009-05-26 03:55:16 UTC
OS: Ubuntu-9.04 
ASIC: RV535

X-stack:

mesa/drm        2.4.5 (Ubuntu-9.04 distro)
mesa/mesa       7.4 (Ubuntu-9.04 distro)
xorg/xserver    1.6.0
xorg/xf86-video-ati     6.12.2 
xorg/lib/libXinerama    8123c94eba27d1a3eb3f509a79c229ddfa1f881a


Steps to reproduce:

1. Start 'glxgears'in a terminal
2. Open another terminal
3. Move the 'glxgears' window and overlap with the terminal window
4. We observe a distortion and that distortion wouldn't refresh for few seconds
5. Also, it doesn't completely refresh until the terminal window is minimized and restored back.
Comment 1 Sunil Mekathotti 2009-05-26 03:57:48 UTC
Created attachment 26218 [details]
Xorg-log
Comment 2 Sunil Mekathotti 2009-05-26 03:58:14 UTC
Created attachment 26219 [details]
xorg.conf
Comment 3 Sunil Mekathotti 2009-05-26 04:03:46 UTC
Created attachment 26220 [details]
glxgears launched
Comment 4 Sunil Mekathotti 2009-05-26 04:05:30 UTC
Created attachment 26221 [details]
glxgears overlapped with a terminal window
Comment 5 Sunil Mekathotti 2009-05-26 04:07:20 UTC
Created attachment 26222 [details]
the terminal window still got a black patch that that doesn't refresh
Comment 6 Adam K Kirchhoff 2009-05-26 05:01:16 UTC
Are you using desktop effects?

Adam
Comment 7 Sunil Mekathotti 2009-05-26 22:16:07 UTC
No... My desktop effects are set to None

(In reply to comment #6)
> Are you using desktop effects?
> Adam

Comment 8 Adam K Kirchhoff 2009-05-27 05:12:43 UTC
Do you have any compositing enabled?  Does this happen with other opengl applications?
Comment 9 Sunil Mekathotti 2009-05-29 02:31:03 UTC
No, composite also not enabled(attached my xorg.conf). Also it happens with other opengl applications like - geartrain,teapot etc. 


(In reply to comment #8)
> Do you have any compositing enabled?  Does this happen with other opengl
> applications?

Comment 10 Michel Dänzer 2009-06-04 02:16:24 UTC
This could be related to bug 21936, you could try the patch from there.
Comment 11 Sunil Mekathotti 2009-06-04 06:31:08 UTC
(In reply to comment #10)
> This could be related to bug 21936, you could try the patch from there.
Please give me the correct bug #. By mistake you have mentioned this bug number in your comment :-)
Comment 12 Michel Dänzer 2009-06-04 07:38:40 UTC
(In reply to comment #11)
> By mistake you have mentioned this bug number in your comment :-)

Oh dear, not the first time this happened to me. :} I meant bug 21653.
Comment 13 Sunil Mekathotti 2009-06-05 05:18:17 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > By mistake you have mentioned this bug number in your comment :-)
> Oh dear, not the first time this happened to me. :} I meant bug 21653.

Thanks for the info. I applied this patch and it worked great! 
Repeated few test with few openGL apps, no corruption observed.

Shall I change the bug status to FIXED?
Comment 14 Alex Deucher 2009-06-05 07:42:55 UTC

*** This bug has been marked as a duplicate of bug 21653 ***