Bug 21945 - mach64 DRI driver hangs machine on X server startup
Summary: mach64 DRI driver hangs machine on X server startup
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-26 12:21 UTC by Christian
Modified: 2019-10-14 13:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2009-05-26 12:21:43 UTC
Hi all!

I am currently trying to enable DRI with my (aged) machine using the mach64 driver.

I have built the drm.ko and mach64.ko according to http://dri.freedesktop.org/wiki/Building (based on git clone git://anongit.freedesktop.org/git/mesa/drm).

The problem can be reproduced as:
1) load drm.ko and mach64.ko (will load fine)
2) restart X

Result: the computer hangs - completely. Caps lock and Scroll lock lights are blinking. Only a hard reset recovers the machine.

Without loading the modules the mach64 driver shipped with the distro will work fine (except DRI of course). Here is some excerpt from the Xorg.0.log:

...
(II) MACH64(0): [drm] SAREA 2200+1208: 3408
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: node name is /dev/dri/card0
[drm] failed to load kernel module "mach64"
(EE) [drm] drmOpen failed.
(EE) MACH64(0): [dri] DRIScreenInit Failed
...

Here are some details on the system:

Machine: Compaq Armada M700, PIII 500MHz

GFX (according to lscpi):
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x (rev 64)
        Subsystem: Compaq Computer Corporation Device b111
        Flags: bus master, stepping, medium devsel, latency 66, IRQ 11
        Memory at 41000000 (32-bit, non-prefetchable) [size=16M]
        I/O ports at 3000 [size=256]
        Memory at 40200000 (32-bit, non-prefetchable) [size=4K]
        [virtual] Expansion ROM at 20000000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel modules: atyfb

Distro: Ubuntu 9.04 (jaunty)
Kernel: 2.6.28-11-generic

X.Org server details (from Xorg.0.log):
X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux aya 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686
Build Date: 09 April 2009  02:10:02AM
xorg-server 2:1.6.0-0ubuntu14 (buildd@rothera.buildd) 

If I can provide any more useful information or test some things please let me know!

Thanks in advance,
Yours,
Christian
Comment 1 hadack 2009-09-13 14:33:08 UTC
I have exactly the same problem, it seems to be introduced by this commit:

http://cgit.freedesktop.org/mesa/drm/commit/?id=957b10695b619d6ed2f1098b00502395d9a3c149
Move vblank_init to driver load time.

This is on Slackware 13.0 running a 2.6.29.6 kernel and xserver 1.6.3

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x (rev 64) (prog-if 00 [VGA controller])
	Subsystem: IBM ThinkPad A20m/A21m
	Flags: bus master, stepping, medium devsel, latency 66, IRQ 11
	Memory at f5000000 (32-bit, non-prefetchable) [size=16M]
	I/O ports at 2000 [size=256]
	Memory at f4200000 (32-bit, non-prefetchable) [size=4K]
	[virtual] Expansion ROM at 40000000 [disabled] [size=128K]
	Capabilities: [50] AGP version 1.0
	Capabilities: [5c] Power Management version 1
	Kernel modules: atyfb

Comment 2 Martin Peres 2019-10-14 13:20:04 UTC
Hi,

Freedesktop's Bugzilla instance is EOLed and open bugs are about to be migrated to http://gitlab.freedesktop.org.

To avoid migrating out of date bugs, I am now closing all the bugs that did not see any activity in the past year. If the issue is still happening, please create a new bug in the relevant project at https://gitlab.freedesktop.org/drm (use misc by default).

Sorry about the noise!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.