Bug 21958 - Stencil-buffer usage causes rendering to front-buffer under compiz with UXA/DRI2
Summary: Stencil-buffer usage causes rendering to front-buffer under compiz with UXA/DRI2
Status: RESOLVED DUPLICATE of bug 19174
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-27 03:47 UTC by Mirco Müller
Modified: 2009-06-01 06:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
isolated, self-contained test-case triggering the stencil-buffer bug (8.61 KB, application/x-bzip)
2009-05-27 03:47 UTC, Mirco Müller
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirco Müller 2009-05-27 03:47:43 UTC
Created attachment 26241 [details]
isolated, self-contained test-case triggering the stencil-buffer bug

Using a special stencil-buffer based technique for drawing concave polygons (e.g. font-glyphs), as also described in the OpenGL red book, causes the client to directly draw to the front-buffer, ignoring the composited enviroment (being run under compiz). Tested with kernels are 2.6.28 and 2.6.30 under Ubuntu 9.04 and Ubuntu Karmic Koala. Tested on GPUs intel GMA 945 and GMA 965 with the the xorg driver 2.7.99.1 and mesa dri "Mesa DRI Intel(R) 945GME GEM 20090326 2009Q1 RC2 x86/MMX/SSE2". An isolated and self-contained example is attached in a tarball.
Comment 1 Gordon Jin 2009-05-29 05:17:06 UTC

*** This bug has been marked as a duplicate of bug 19174 ***
Comment 2 Mirco Müller 2009-06-01 06:33:05 UTC
Thanks for the hint regarding bug 19174. I fixed my code and don't have the stencil buffer issue anymore. Embarrassing I used glDrawBuffer (GL_FRONT_AND_BACK) instead of just glDrawBuffer (GL_BACK).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.