Bug 22010 - [945GM] [Bisected] X hang after suspend
[945GM] [Bisected] X hang after suspend
Status: RESOLVED DUPLICATE of bug 20520
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
Other All
: medium normal
Assigned To: Carl Worth
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-30 19:43 UTC by Jie Luo
Modified: 2009-06-16 15:24 UTC (History)
0 users

See Also:


Attachments
intel_gpu_top (510 bytes, text/plain)
2009-06-05 19:59 UTC, Jie Luo
no flags Details
intel_gpu_dump (320.37 KB, text/plain)
2009-06-05 20:07 UTC, Jie Luo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jie Luo 2009-05-30 19:43:29 UTC
The screen corrupt and stayed still after suspend. You can move cursor around, but the server does not response. I can access to the machine through ssh, nothing show up in the log and dmesg. The cpu usage is normal too. I can't restart X, and have to restart the whole machine.

After doing some bitsect with git, I found the bad commit is

commit 8e942b70cb9a784b3f1311affd6fc74c4bcf68bb
Author: Carl Worth <cworth@cworth.org>
Date:   Thu May 21 13:12:52 2009 -0700

    Revert "Rely on BO pixmaps being present in acceleration paths."
    
    This reverts commit 4653a7db622ad54a3182d93c81331765d930db34.
    
    Eric was getting a little too ambitious about our brave, new world.
    We do still want the driver to work with old, non-GEM kernels
    after all.


After revert this one, everything is fine.

kernel: 2.6.30-rc7-git4
xserver: 1.6.1.901
xf86-video-intel: 8e942b70cb9a784b3f1311affd6fc74c4bcf68bb
Comment 1 Jie Luo 2009-06-05 19:40:03 UTC
Some updates on this bug. It seams that with kernel 2.6.29.3 everything works fine. Besides after revert 8e942b70cb9a784b3f1311affd6fc74c4bcf68bb I still hang for one time. So the bug might be lurk in somewhere else. I'll retest with latest kernel and report back.
Comment 2 Jie Luo 2009-06-05 19:58:08 UTC
OK, after retest with kernel 2.6.30-r8-git1, the hang still there. Maybe it is a regression of the kernel drm driver. I'll try to bisect the kernel instead.
Comment 3 Jie Luo 2009-06-05 19:59:08 UTC
Created attachment 26480 [details]
intel_gpu_top
Comment 4 Jie Luo 2009-06-05 20:07:39 UTC
Created attachment 26481 [details]
intel_gpu_dump

This is what intel_gpu_dump shows after stripe a lot of MI_NOOP at the end of file.
Comment 5 Jie Luo 2009-06-12 23:31:43 UTC
It seams the same issue has also been reported as http://bugs.freedesktop.org/show_bug.cgi?id=22039
Comment 6 Jesse Barnes 2009-06-16 15:24:09 UTC
Marking as a DUP of an older 945GM hang... this is a high priority bug.

*** This bug has been marked as a duplicate of bug 20520 ***