Bug 2213 - Crash after 10 minutes to a few hours of operation
Summary: Crash after 10 minutes to a few hours of operation
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 6.8.0
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: want-backtrace
Depends on:
Blocks:
 
Reported: 2005-01-03 22:27 UTC by Lin
Modified: 2006-04-03 23:45 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lin 2005-01-03 22:27:36 UTC
The OS (Linux Fedora Core 3) crashes after about an hour of use.  The cursor
either freezes or disappears, and the machine must be power cycled to restart
it.  Ctrl-alt-bksp or Ctrl-alt-delete does not work.  This bug also occurs in
6.8.1.  The crash is not browser related, since it also occurs when working on
an xterm.

Is there any kind of HOWTO on how to fix this kind of problem myself?  Download
the source code, build it, link to the new server.  What next?  Obviously this
problem is caused by some sort of non-deterministic corruption, and is best
debugged by writing periodically to a log file.  Is there any debug support in
the code that can be activated via the xorg.conf file?  Failing that, how about
ifdef's that can be activated.  Where should the bracketing print statements be?
 It will probably take a while to zero in on the bug, but where is it most
likely to be?  In the drivers section for mga?

Thanks in advance!
Comment 1 Adam Jackson 2005-07-03 14:46:14 UTC
starting with the 6.8.99.14 snapshot, on linux systems, the X server can print
its own backtrace when it crashes.  please confirm that these bugs are still
valid with 6.8.99.14 or later, and if they are please attach a the server log
from the crash.
Comment 2 Erik Andren 2006-04-04 16:45:25 UTC
I'm closing this bug due to the lack of activity. If the problem still persists
with a current version of xorg, please reopen.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.