Bug 22254 - Xorg crashes without monitor connected
Summary: Xorg crashes without monitor connected
Status: RESOLVED DUPLICATE of bug 14611
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: Gordon Jin
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-12 05:18 UTC by Charles Bovy
Modified: 2009-06-12 11:19 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.conf (1.64 KB, text/plain)
2009-06-12 05:19 UTC, Charles Bovy
no flags Details
Xorg log (22.33 KB, text/plain)
2009-06-12 05:19 UTC, Charles Bovy
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Bovy 2009-06-12 05:18:39 UTC
System environment:
chipset: G45
uname -m: x86_64
libdirm: 2.4.11
kernel: 2.6.30-rc8
distri: Ubuntu Jaunty
Board: GA-EG45M-DS2H
Display: HDMI Panasonic

Description:
While booting my system with monitor powered off, Xorg won't start and crashes with:

(EE) intel(0): No valid modes.

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4f1d86]
1: /usr/bin/X(xf86SigHandler+0x41) [0x478311]
2: /lib/libc.so.6 [0x7f88e2ef6040]
3: /usr/lib/xorg/modules/drivers//intel_drv.so [0x7f88e0f3ccc6]
4: /usr/bin/X(xf86DeleteScreen+0x7e) [0x48086e]
5: /usr/bin/X(InitOutput+0xe1d) [0x46fbdd]
6: /usr/bin/X(main+0x20e) [0x433d2e]
7: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f88e2ee15a6]
8: /usr/bin/X [0x433369]
Saw signal 11.  Server aborting.
 ddxSigGiveUp: Closing log

See full Xorg.0.log.

When monitor is powered on, Xorg starts perfect with the correct modes.
Xorg should start always, also without monitor connected. 

Reproducing steps:
Boot system without monitors connected.
Comment 1 Charles Bovy 2009-06-12 05:19:21 UTC
Created attachment 26714 [details]
Xorg.conf
Comment 2 Charles Bovy 2009-06-12 05:19:43 UTC
Created attachment 26715 [details]
Xorg log
Comment 3 Gordon Jin 2009-06-12 11:19:19 UTC
this is a known server issue.

*** This bug has been marked as a duplicate of bug 14611 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.