Bug 2229 - glReadPixel (or glDrawPixel) causes segfaults
glReadPixel (or glDrawPixel) causes segfaults
Status: RESOLVED DUPLICATE of bug 2317
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r200
git
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 13:45 UTC by Roland Scheidegger
Modified: 2009-08-24 12:22 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Scheidegger 2005-01-05 13:45:43 UTC
demos/readpix will segfault when moving the window completely out of the screen
(I pushed it to bottom/left).
With R200_DEBUG set to pixel, this is what I got:
r200ReadPixels
r200TryReadPixels
r200TryReadPixels: dest not GART
r200DrawPixels
r200TryDrawPixels
r200TryDrawPixels: not GART memory
r200DrawPixels
r200TryDrawPixels
r200TryDrawPixels: not GART memory
r200ReadPixels
r200TryReadPixels
r200TryReadPixels: dest not GART
Speicherzugriffsfehler

I have no backtrace unfortunately, be warned that the segfault obviously happens
after a LOCK_HARDWARE()...
Comment 1 Dieter Nützel 2005-01-24 09:16:44 UTC
Applies only to r200 from Mesa CVS (linux-dri). 
 
X.org CVS r200_dri.so works. 
Comment 2 Roland Scheidegger 2005-06-30 04:44:38 UTC

*** This bug has been marked as a duplicate of 2317 ***
Comment 3 ajax at nwnk dot net 2009-08-24 12:22:58 UTC
Mass version move, cvs -> git