Bug 22428 - [bisected 945GME]mesa xdemo/glxcontexts run aborted with error: Assertion `!obj->Pointer'
[bisected 945GME]mesa xdemo/glxcontexts run aborted with error: Assertion `!o...
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
unspecified
Other Linux (All)
: high major
Assigned To: Eric Anholt
: regression
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 00:37 UTC by liuhaien
Modified: 2009-06-30 20:04 UTC (History)
1 user (show)

See Also:


Attachments
xorg.0.log (21.54 KB, text/plain)
2009-06-23 00:37 UTC, liuhaien
Details
xorg conf file (4.19 KB, text/plain)
2009-06-23 01:06 UTC, liuhaien
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2009-06-23 00:37:32 UTC
Created attachment 27026 [details]
xorg.0.log

System Environment:
--------------------------
Host:           x-aspire1
Arch:           i386
Platform:        945GME
Libdrm:         (master)790097c51330090b2b7b90429b9ab8ddf259fd8e
Mesa:           (mesa_7_5_branch)2f184d0d9f4600a20022887674b77f45ee6b728e
Xserver:              
(server-1.6-branch)dbac41b624e4aa86a6a184b7ebb52bfdd367bbf0
Xf86_video_intel:              
(master)418b473824e81a84b929b9d100f85f532b94422b
Kernel:             (for-linus)0e7ddf7eeeef5aea85412120539ab5369577faeb

Bug detailed description:
-------------------------
mesa xdemo/System Environment:
--------------------------
Host:           x-aspire1
Arch:           i386
Platform:        945GME
Libdrm:         (master)790097c51330090b2b7b90429b9ab8ddf259fd8e
Mesa:           (mesa_7_5_branch)2f184d0d9f4600a20022887674b77f45ee6b728e
Xserver:              
(server-1.6-branch)dbac41b624e4aa86a6a184b7ebb52bfdd367bbf0
Xf86_video_intel:              
(master)418b473824e81a84b929b9d100f85f532b94422b
Kernel:             (for-linus)0e7ddf7eeeef5aea85412120539ab5369577faeb

Bug detailed description:
-------------------------
mesa xdemo/glxcontexts run aborted with below error:
glxcontexts: intel_buffer_objects.c:103: intel_bufferobj_free: Assertion `!obj->Pointer' failed.
Aborted

Reproduce Steps:
------------------
1. xinit&
2. run mesa xdemo/glxcontexts
Comment 1 liuhaien 2009-06-23 01:06:27 UTC
Created attachment 27029 [details]
xorg conf file
Comment 2 liuhaien 2009-06-23 01:08:32 UTC
mesa demo/isosurf got the similar issue,but the error is as below:
isosurf: intel_buffer_objects.c:103: intel_bufferobj_free: Assertion `!obj->Pointer' failed.
Aborted
Comment 3 Brian Paul 2009-06-23 08:30:08 UTC
I can't reproduce this here with Mesa 7.5.
I'm checking in some fixes for glxcontexts.c though.
Comment 4 Jonathan Michalon 2009-06-25 03:35:02 UTC
Same issue here. I'm using version of
7.5.0~git20090622+mesa-7-5-branch.abfd56c2-0ubuntu0sarvatt
package. No 3D application working anymore, switching to High importance.
Comment 5 liuhaien 2009-06-26 01:51:37 UTC
same issue happens in playing neverball game.
Comment 6 Gordon Jin 2009-06-28 18:37:20 UTC
Ian, can you reproduce?

I'm increasing severity since it impacts real-world application.
Comment 7 liuhaien 2009-06-28 19:34:40 UTC
the issue also impacts our glean case (texgen,vertattrib),I think it is a regression in mesa 7.5 branch. I am trying to bisect.
Comment 8 liuhaien 2009-06-28 21:59:22 UTC
I find the reason, below commit caused this issue:
commit ff3da0966fc91cd5bcfed994e5edadbf25903c47
Author: Eric Anholt <eric@anholt.net>
Date:   Tue Jun 2 06:53:40 2009 -0700

	i915: Don't put VBOs in graphics memory unless required for an operation.

	This saves doing swtnl from uncached memory, which is painful.  Improves
	clutter test-text performance by 10% since it started using VBOs.
	(cherry picked from commit a945e203d4fe254593bc0c5c5d6caca45e65f9f7)
Comment 9 Eric Anholt 2009-06-30 13:30:04 UTC
commit c72261f2a886e1f53025c2cf4b38b33ccfd62857
Author: Eric Anholt <eric@anholt.net>
Date:   Mon Jun 29 18:48:27 2009 -0700

    i915: Fix assertion failure on remapping a non-BO-backed VBO.
    
    Failure to set the obj->Pointer back to null tripped up the assertion.
    Bug #22428.
    (cherry picked from commit 57a06d3a48c9af1067ec05e3ad96c58f4b9b99be)
Comment 10 liuhaien 2009-06-30 20:04:33 UTC
verified with below commits:
Libdrm:		(master)de1ed01214874dcdd6116ff2587c8710d6ed4d2d
Mesa:		(mesa_7_5_branch)4e43126a5915b1233c89c61400c8270d23d48ea3
Xserver:	(server-1.6-branch)a7a93c12f91e0de72868f17a555215f1795d9e2f
Xf86_video_intel:		(master)afac333bef4a0ac934f0e4d933dc5053d81ca88c
Kernel:       (qa-branch)07a2039b8eb0af4ff464efd3dfd95de5c02648c6