Bug 22430 - localized package titles truncated at first non-ASCII character
Summary: localized package titles truncated at first non-ASCII character
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-apt (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-23 01:24 UTC by Ivan Masár
Modified: 2012-01-05 10:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot of gpk-application showing the problem (96.16 KB, image/png)
2009-06-23 01:24 UTC, Ivan Masár
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Masár 2009-06-23 01:24:47 UTC
Created attachment 27030 [details]
Screenshot of gpk-application showing the problem

In gnome-packagekit (packagekit-gnome) on Ubuntu 9.04 with apt option
APT::Acquire::Translation "sk";

gpk-application seems to show package titles truncated at first non-ascii character. Screenshot attached. For what the localized titles should look like, see http://packages.ubuntu.com/sk/jaunty/aspell-en

Also, nothing shows in the botom left window, I would expect package description to show there...

This makes gpk unusable in localized environment. I didn't check whether it's fixed in a later version.


$ dpkg -l '*packagekit*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                      Version                   Description
+++-=========================-=========================-==================================================================
ii  libpackagekit-glib11      0.3.14-0ubuntu5           Library for accessing PackageKit using GLib
ii  packagekit                0.3.14-0ubuntu5           provides a software installation daemon
ii  packagekit-backend-apt    0.3.14-0ubuntu5           APT backend for packagekit
un  packagekit-backend-smart  <none>                    (no description available)
ii  packagekit-gnome          0.3.13-0ubuntu1           graphical distribution neutral software management tools
ii  python-packagekit         0.3.14-0ubuntu5           PackageKit Python bindings
Comment 1 Richard Hughes 2009-06-23 01:26:55 UTC
What does "pkcon search name aspell" print?
Comment 2 Ivan Masár 2009-06-23 02:44:22 UTC
Same truncated titles:

$ pkcon search name aspell
installed   	aspell-0.60.6-1                         	Kontrola pravopisu GNU Aspell
available   	aspell-af-20070203-3                    	The Africaans dictionary for aspell
available   	aspell-am-0.03-1-3                      	amharsk
available   	aspell-ar-0.0.20060329-3                	arabsk
available   	aspell-ar-large-1.2-0-1                 	obrovsk
available   	aspell-bg-3.0-9                         	bulharsk
available   	aspell-bn-0.60.0.01.1.1-7               	beng
available   	aspell-br-0.50-2-6                      	bret
available   	aspell-ca-0.6-5                         	katal
installed   	aspell-cs-0.0.20040614.1-2              	
available   	aspell-cy-0.50-3-6                      	walesk
available   	aspell-da-1.6.18-1                      	d
available   	aspell-de-20071211-1ubuntu1             	nemeck
available   	aspell-de-alt-1:2-25                    	German dictionary for aspell (old spelling)
...
Comment 3 Ivan Masár 2009-06-23 06:28:31 UTC
Tested in Karmic, same problem persists.

By default Karmic Alpha 2 shows non-localized language names (both pkcon and gpk-application) though other tools show localized ones. I think this is caused by the fact that APT configuration in Ubuntu doesn't contain the 'APT::Acquire::Translation "sk";' option. After I added the apt option the problem was the same as in Jaunty.


$ dpkg -l '*packagekit*'
Požadovaný=Neznámy/Inštalovať/Odstrániť/Vyčistiť
| Stav=Nie/Inštalovaný/Konfig-súbory/Rozbalený/Zlý-konfig/Polo-inštalovaný/očak-spúšť/čaká-na-spúšť
|/ Chyba?=(žiadna)/Podržať/Reinšt-vyžadovaná/X=oba-problémy (Stav,Chyba: veľké písmeno=zle)
||/ Názov                    Verzia                    Popis
+++-=========================-=========================-==================================================================
ii  libpackagekit-glib11      0.4.8-0ubuntu1            Library for accessing PackageKit using GLib
ii  packagekit                0.4.8-0ubuntu1            provides a software installation daemon
ii  packagekit-backend-apt    0.4.8-0ubuntu1            APT backend for packagekit
un  packagekit-backend-smart  <žiadna>                 (popis nie je k dispozícii)
ii  packagekit-gnome          2.27.2-0ubuntu2           graphical distribution neutral software management tools
ii  python-packagekit         0.4.8-0ubuntu1            PackageKit Python bindings
Comment 4 Ivan Masár 2009-06-23 06:36:45 UTC
The default value of the translation APT option (checked in Debian Lenny, Ubuntu Karmic and Jaunty) is
$ apt-config dump | grep Translation
APT::Acquire::Translation "environment";

I suspect you don't detect it in PK and other package managers do because you show English strings and other tools show localized ones. Should I file another bug for this?
Comment 5 Jean-François Fortin Tam 2012-01-05 10:41:51 UTC
Hi there,
This bug report is very old and based on a version not supported anymore. By upgrading to a newer version of PackageKit you could receive bug fixes and new functionality. You may need to upgrade your Linux distribution to obtain a newer version of PackageKit.
Please feel free to reopen this bug if the problem still occurs with the latest version.


bug/show.html.tmpl processed on Mar 29, 2017 at 18:57:23.
(provided by the Example extension).