Bug 22569 - Sansa C2xx MSC detection fails when using rockbox firmware and OE AutoDetect mode
Sansa C2xx MSC detection fails when using rockbox firmware and OE AutoDetect ...
Status: RESOLVED DUPLICATE of bug 20717
Product: hal
Classification: Unclassified
Component: hal-info
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: David Zeuthen (not reading bugmail)
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 18:29 UTC by kitten
Modified: 2010-03-25 09:06 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kitten 2009-06-30 18:29:00 UTC
When using rockbox firmware hal fails to detect it as a MSC device and does not allow mounting. tested on slackware, ubuntu, debian. 

Rockbox lsusb -v reports 
#idVendor           0x0781 SanDisk Corp.
#idProduct          0x7450 Sansa C250
#bcdDevice            1.00
#iManufacturer           1 Rockbox.org
#iProduct                2 Rockbox media player
#bInterfaceClass         8 Mass Storage
#bInterfaceSubClass      6 SCSI
#bInterfaceProtocol     80 Bulk (Zip)


while the OE firmare lsusb -v reports
#idVendor           0x0781 SanDisk Corp.
#idProduct          0x7451 Sansa C240
#bcdDevice            7.20
#iManufacturer           1 SanDisk
#iProduct                2 Sansa c240
#bInterfaceClass         8 Mass Storage
#bInterfaceSubClass      6 SCSI
#bInterfaceProtocol     80 Bulk (Zip)
 
Product ID Ox7450 is reported when OE firmware is set to "AutoDetect" mode and is also unmountable

SVN version of rockbox firmware has the Product ID set to 0x7451 and it is then properly detected as a MSC device. HAL should use interface class to determine interface type instead of Product ID
Comment 1 Bastien Nocera 2010-03-25 09:06:55 UTC
Already discussed in bug 20717.

*** This bug has been marked as a duplicate of bug 20717 ***