Bug 22608 - Screen does not update when using DRI/DRM if non-root
Summary: Screen does not update when using DRI/DRM if non-root
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2009-07-03 14:10 UTC by Michael Pyne
Modified: 2009-07-24 16:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

dmesg output of non-root X session. (30.42 KB, text/plain)
2009-07-03 14:13 UTC, Michael Pyne
no flags Details
dmesg output of root X session (30.59 KB, text/plain)
2009-07-03 14:15 UTC, Michael Pyne
no flags Details

Description Michael Pyne 2009-07-03 14:10:52 UTC
When bringing up an X11 desktop using latest (as of July 2 2009) kernel DRM, radeon DRM, xf86-video-ati (master), mesa (master), and libdrm (with libdrm_radeon built), the screen does not update in either of the two desktops I tested (KDE 4.3, Fluxbox 1.1.1).

You can move the mouse cursor around just fine and click on things, but you can't see what you're clicking on. (You can tell if you're on a window edge since the mouse cursor changes).

With fluxbox, the stoppage of screen updates is immediate, no desktop ever shows up.

With KDE 4.3, the stoppage seems to happen after the desktop is shown at around the same time.

If I run as root I have no issues whatsoever (I've only tested fluxbox however, not KDE).

I have the DRM module debug enabled, so I will attach dmesg output from my user account and root account runs.

Linux: 2.6.31-rc1, at git commit ac2a921 (x86_64, SMP kernel, Linus's tree)
Mesa: git master branch 060c7f2321f72503c14f9f3f7bb27d59d8a90224
xf86-video-ati: git master branch 8d2f712eaf1e569fd92bbe2db5aceb43b7b367d1
libdrm: git master branch 72a29340ea3225550db6b009f4e50c77c7b1f394
xorg-xserver: git master branch 3525d140567e0ad5f0184e4b37893c47239e1628

DRM and DRM-Radeon modules are compiled directly into the kernel.

One last data point -- this bug was not present for me about a week or so ago (when I had kms-support instead of master).
Comment 1 Michael Pyne 2009-07-03 14:13:02 UTC
Created attachment 27367 [details]
dmesg output of non-root X session.

The kernel log ring buffer was cleared using dmesg -c before running startx as non-root (fluxbox).  After moving the mouse around and confirming no screen updates, I used Ctrl-Alt-Backspace to dump X and recorded this output.
Comment 2 Michael Pyne 2009-07-03 14:15:07 UTC
Created attachment 27368 [details]
dmesg output of root X session

Like for the other attachment, dmesg -c was used to clear the kernel ring buffer, I ran startx /usr/bin/fluxbox as root, moved the mouse enough to bring up the fluxbox menu and exit, and then recorded the dmesg output as this attachment.
Comment 3 Michel Dänzer 2009-07-08 07:33:37 UTC
I can't seem to find any reference to the register the kernel complains about in xf86-video-ati... does this still happen with current Git? If so, please also attach the full Xorg.0.log file.
Comment 4 Michael Pyne 2009-07-08 16:05:40 UTC
Well, current git causes Xorg to segfault immediately with DRI2 enabled so as soon as I figure that out I'll confirm if I still have the issue and attach Xorg.0.log as necessary.
Comment 5 Michael Pyne 2009-07-24 16:58:30 UTC
Updates to kernel's DRM between 2.6.31-rc2 and rc4 appear to have fixed the issues I was still having after getting Mesa to run without segfaults.  I have other issues now but this bug appears fixed.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.