Bug 2265 - OO.o OpenDocumentText (odt) files recognized as zipped archives
OO.o OpenDocumentText (odt) files recognized as zipped archives
Status: RESOLVED FIXED
Product: shared-mime-info
Classification: Unclassified
Component: general
unspecified
x86 (IA32) Linux (All)
: high normal
Assigned To: Jonathan Blandford
:
: 2629 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 15:12 UTC by Vincent Noel
Modified: 2005-03-09 13:58 UTC (History)
1 user (show)

See Also:


Attachments
Proposed patch (2.66 KB, patch)
2005-03-09 08:31 UTC, David Zeuthen (not reading bugmail)
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Noel 2005-01-11 15:12:50 UTC
The new OpenDocumentText (odt extension) files, coming in OpenOffice 2.0 and
already available in the beta (1.9) are recognized as "application/zip". It
makes sense as they actually *are* zipped, but it would be nice if nautilus was
able to make the difference :) I think this was already fixed once for the
previous OpenOffice formats (oot or something like that).

The OpenDocument formats are described somewhere in here
http://marketing.openoffice.org/2.0/featureguide.html
Comment 1 Vincent Noel 2005-01-11 15:15:06 UTC
Just for information, I had previously filed this bug in the gnome bugzilla (bug
163719).
Comment 2 David Zeuthen (not reading bugmail) 2005-03-09 08:31:06 UTC
Created attachment 2061 [details] [review]
Proposed patch

jrb: I've just put this one into Fedora Rawhide and it appears to work for me
Comment 3 Vincent Noel 2005-03-09 10:45:49 UTC
*** Bug 2629 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Blandford 2005-03-09 13:37:03 UTC
Patch looks good to me.
Comment 5 Jonathan Blandford 2005-03-10 08:58:10 UTC
committed..