Bug 22699 - [i830] unable to launch Xorg on Fujitsu Stylistic ST4120PW
Summary: [i830] unable to launch Xorg on Fujitsu Stylistic ST4120PW
Status: RESOLVED DUPLICATE of bug 17902
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Gordon Jin
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-10 01:19 UTC by Bryce Harrington
Modified: 2009-07-12 19:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log using the vesa (30.68 KB, application/octet-stream)
2009-07-10 01:19 UTC, Bryce Harrington
no flags Details
Log file when running with Driver "intel" in xorg.conf on Karmic Alpha-2 (10.11 KB, text/plain)
2009-07-10 01:21 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2009-07-10 01:19:44 UTC
Created attachment 27545 [details]
Xorg.0.log using the vesa

Forwarding this bug from Ubuntu reporter chrome:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/362582

[Problem]
After starting it blinks screen a few times, then a black screen with vertical white stripes growing for a few seconds and finally filling whole screen.  Can vt-switch away.

First started in Jaunty but same issue is seen on Karmic Alpha-2.


[Original Report]
I'm unable to install Jaunty on Fujitsu Stylistic ST4120PW tabletpc computer. It has Intel 830M graphics controller. When I try to install from a cd, it prepares to launch X, after starting it blinks screen a few times, and finally I get black screen with vertical white stripes growing for a few seconds and finally filling whole screen. The system underneath doesn't crash. I can switch to text console and it works, and then when returning to X just the same white stripes appear. Sometimes, but not always, when switching console from text mode to X I can see X desktop for a split second just after the switch, but it instantly disappears and the stripes start to fade black to white. Oh, and stripes are not exactly the same every time, sometimes there are more stripes, and sometimes less.

Exactly the same happens when trying to install in safe mode.

I tried switching drivers manually by editing xorg.conf, and this is what happens when trying to start X after edits (the xorg.conf file is all default, with just 'Driver ...' line added):

1) Driver "intel"
result:
(EE) intel(0): sil164 not detected got 5: from DVOI2C_E Slave 112.
(EE) intel(0): tfp410 not detected got VID 1305: from VOI2C_E Slave 112.
(EE) intel(0): No valid modes.
(EE) Screen(s) found, but none have a usable configuration.

Above messages appear about 2 seconds after running 'X' and show after a split-second black screen.

2) Driver 'i810'
result:
(EE) No devices detected.

This time the messages appear after about 1 second and a split-second black screen. I don't know if this driver is supposes to support 830M or not, I just gave it a try.

3) And finally: Driver 'vesa'
result:
After running 'X' it shows black screen for about 10 seconds, then it turns off the backlight for about 2 seconds, and then it turns on the backlight again and start the black to white stripes fading. Switching to the text console from which I started X shows some logs, but they are related to XKEYBOARD, so I don't consider them important.

In Xorg.0.log I can find lines about different modules loading. Some maybe interesting lines are:
(II) VESA(0): Not using built-in mode "640x480" (no mode of this name)
...
(WW) VESA(0): No valid modes left. Trying less strict filter
...
(**) VESA(0): Using "Shadow Framebuffer"
...

Unfortunately doesn't work on Karmic Alpha-2 too. Boot process looks the same as on Jaunty (as described in first message). Xorg message log looks similar as earlier
Comment 1 Bryce Harrington 2009-07-10 01:21:09 UTC
Created attachment 27546 [details]
Log file when running with Driver "intel" in xorg.conf on Karmic Alpha-2

When this boots, the following is shown in the terminal:

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.6.1.901 (1.6.2 RC 1)
Release Date: 2009-5-8
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux ubuntu 2.6.30-8-generic #9-Ubuntu SMP Wed Jun 3 15:23:55 UTC 2009 i686
Build Date: 23 May 2009  09:44:43PM
xorg-server 2:1.6.1.901-2ubuntu1 (buildd@rothera.buildd) 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun 29 21:35:20 2009
(==) Using config file: "/etc/X11/xorg.conf"
(EE) intel(0): sil164 not detected got 5: from DVOI2C_E Slave 112.
(EE) intel(0): tfp410 not detected got VID 1305: from DVOI2C_E Slave 112.
(EE) intel(0): No valid modes.

Backtrace:
0: Xorg(xorg_backtrace+0x3b) [0x8134efb]
1: Xorg(xf86SigHandler+0x55) [0x80c81c5]
2: [0xeb1400]
3: /usr/lib/xorg/modules/drivers//intel_drv.so [0x277b6e]
4: Xorg(xf86DeleteScreen+0x6b) [0x80d50cb]
5: Xorg(InitOutput+0x548) [0x80b06e8]
6: Xorg(main+0x1d3) [0x8072213]
7: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xa017a5]
8: Xorg [0x8071881]
Saw signal 11.  Server aborting.
 ddxSigGiveUp: Closing log
 ddxSigGiveUp: re-raising 11
Comment 2 Gordon Jin 2009-07-12 19:32:32 UTC

*** This bug has been marked as a duplicate of bug 17902 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.