Bug 22834 - Usability regression
Summary: Usability regression
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-18 06:37 UTC by Stepan Zastupov
Modified: 2009-07-20 09:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stepan Zastupov 2009-07-18 06:37:38 UTC
After the fresh F11 installation, I've thought packagekit is a most user friendly package manager front-end. But after updates I've noticed some usability regressions.

1) update-icon stopped to show transactions progress. I'll be glad to /apps/gnome-packagekit/update-icon/watch_active_transactions enabled by default again.
2) gpk-application starts in maximized window and does not store window size.
Comment 1 Richard Hughes 2009-07-20 08:24:02 UTC
(In reply to comment #0)
> 1) update-icon stopped to show transactions progress. I'll be glad to
> /apps/gnome-packagekit/update-icon/watch_active_transactions enabled by default
> again.

By design. Why do you think you need to interact with the icon for active transactions?

> 2) gpk-application starts in maximized window and does not store window size.

It should only do that if the screen size is very small -- what screen dimensions do you have?
Comment 2 Stepan Zastupov 2009-07-20 09:13:23 UTC
(In reply to comment #1)
> (In reply to comment #0)
> By design. Why do you think you need to interact with the icon for active
> transactions?

By the same reason why ./configure display message for each test :) Ok, gpk show progress on install, update, etc... so there is no reason to show transaction progress. But when updates available, gpk-update-icon provides drop-down menu with option "Install updates" which performs update silently. I'm not sure about current version, but previous version had described behavior.

> It should only do that if the screen size is very small -- what screen
> dimensions do you have?
> 
1280 x 800
Comment 3 Richard Hughes 2009-07-20 09:41:14 UTC
(In reply to comment #2)
> By the same reason why ./configure display message for each test :) Ok, gpk
> show progress on install, update, etc... so there is no reason to show
> transaction progress. But when updates available, gpk-update-icon provides
> drop-down menu with option "Install updates" which performs update silently.
> I'm not sure about current version, but previous version had described
> behavior.

Yes, we're thinking about nuking that option altogether, and just providing a link to the update viewer.

> > It should only do that if the screen size is very small -- what screen
> > dimensions do you have?
> > 
> 1280 x 800

Right, then it's by design, as your height is very small.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.