Bug 22836 - X crashes when exiting
X crashes when exiting
Status: RESOLVED DUPLICATE of bug 20516
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.4 (2008.09)
Other All
: medium normal
Assigned To: Gordon Jin
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-18 11:38 UTC by Pacho Ramos
Modified: 2009-07-18 19:56 UTC (History)
0 users

See Also:


Attachments
Xorg.0.log (16.14 KB, text/plain)
2009-07-18 11:38 UTC, Pacho Ramos
no flags Details
dmesg.out (36.84 KB, text/plain)
2009-07-18 16:48 UTC, Pacho Ramos
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos 2009-07-18 11:38:12 UTC
Created attachment 27816 [details]
Xorg.0.log

I am suffering this problem when exiting from a X session (clicking on exit from gnome or icewm, or simply hitting Ctrl+C from console running "startx"). I get this trace:
Backtrace:
0: X(xorg_backtrace+0x26) [0x4e9b76]
1: X(xf86SigHandler+0x39) [0x487559]
2: /lib/libc.so.6 [0x7fa32c82d290]
3: /usr/lib/libdrm_intel.so.1 [0x7fa32b6a49f8]
4: /usr/lib64/xorg/modules/drivers//intel_drv.so [0x7fa32b8d61c6]
5: X [0x4fd4d9]
6: X [0x51dad3]
7: X(main+0x4dc) [0x43064c]
8: /lib/libc.so.6(__libc_start_main+0xe6) [0x7fa32c8195c6]
9: X [0x42f9a9]

Fatal server error:
Caught signal 11.  Server aborting

I have tested some driver version, all fail in the same way:
xf86-video-intel-2.6.3
xf86-video-intel-2.7.1

With these libdrm versions:
libdrm-2.4.5
libdrm-2.4.9
libdrm-2.4.11 (2.4.12 causes a different crash on same circunstances)

I am running xorg-server-1.5.3

This is my lspci output:
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 0a)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 0a)
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 0a)
00:02.1 Display controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 0a)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)


I am using it without any xorg.conf file. I attach full xorg.0.log file

My kernel is 2.6.30

Thanks
Comment 1 Pacho Ramos 2009-07-18 16:47:24 UTC
Maybe a kernel issue :-/
# cat /proc/mtrr 
reg00: base=0x000000000 (    0MB), size=65536MB, count=1: write-back
reg01: base=0x0bf700000 ( 3063MB), size=    1MB, count=1: uncachable
reg02: base=0x0bf800000 ( 3064MB), size=    8MB, count=1: uncachable
reg03: base=0x0bf600000 ( 3062MB), size=    1MB, count=1: uncachable
reg04: base=0x0c0000000 ( 3072MB), size= 1024MB, count=1: uncachable
Comment 2 Pacho Ramos 2009-07-18 16:48:20 UTC
Created attachment 27824 [details]
dmesg.out
Comment 3 Gordon Jin 2009-07-18 19:56:01 UTC

*** This bug has been marked as a duplicate of bug 20516 ***