Bug 22858 - Various roster fixes
Summary: Various roster fixes
Status: NEEDINFO
Alias: None
Product: Telepathy
Classification: Unclassified
Component: gabble (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL: http://git.collabora.co.uk/?p=user/wj...
Whiteboard:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2009-07-20 12:32 UTC by Will Thompson
Modified: 2011-10-13 05:41 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Will Thompson 2009-07-20 12:32:41 UTC
I've fixed a bunch of roster bugs. From NEWS in my 'i-hate-rosters' branch:

* Gabble no longer erroneously hides Google Talk contacts who which were
  automatically added to your roster, and contacts who Google incorrectly
  thinks are aliases for another JID).

* Removing a contact from 'subscribe' while they're in remote-pending ("Oops! I
  didn't mean to subscribe to Randall's presence!") now works. This is on top
  of the fix for fd.o #21547 in 0.7.28, which made removing the
  contact from 'stored' work.  Previously, while the subscription request was
  correctly rescinded, Gabble didn't expose it correctly on the 'subscribe'
  channel.

* Contacts no longer "flicker" to and from subscribe:remote-pending when you
  subscribe to them on a Google Talk account. This was a regression in 0.7.28,
  caused by fixing fd.o #21547.
Comment 1 Guillaume Desmottes 2009-07-21 02:16:51 UTC
The branch looks fine according my (very limited) understanding of the Google roster and all its mysteries.

2 typo in the NEWS:

"who which" ?

for another JID).
You are closing a not opened parenthesis.
Comment 2 Will Thompson 2009-07-21 03:11:47 UTC
(In reply to comment #1)
> 2 typo in the NEWS:

I've updated the branch accordingly.

Think this is okay to go? The Google roster is not all that mysterious, and I've tried to add enough information in comments that people in the future touching this stuff won't have to re-reverse-engineer the bugs being worked around. :)
Comment 3 Will Thompson 2009-07-21 06:26:28 UTC
Merged, will be in 0.7.31. Thanks for the review!
Comment 4 pterion 2011-10-13 05:28:31 UTC
The problem still occurs with version 0.8.12-0ubuntu1.1 on Ubuntu Lucid 10.04 LTS.
Comment 5 Will Thompson 2011-10-13 05:41:07 UTC
We (Telepathy upstream) do not support Gabble 0.8.x any more. So, does the bug occur with a more modern version of Gabble? If so, please attach debug logs from Gabble as per <http://telepathy.freedesktop.org/wiki/Debugging>, and describe which aspect of “the problem” you are referring to.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.