Bug 22885 - [PATCH] xserver-1.6: Fix keyboard repeat problem
Summary: [PATCH] xserver-1.6: Fix keyboard repeat problem
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-21 23:42 UTC by Kim Woelders
Modified: 2009-08-02 09:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Fix key repeat problem (801 bytes, patch)
2009-07-21 23:42 UTC, Kim Woelders
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kim Woelders 2009-07-21 23:42:49 UTC
Created attachment 27898 [details] [review]
Fix key repeat problem

I have had trouble with keys getting "stuck" and autorepeating until some  
key press. I believe the problem is related to clients grabbing the  
keyboard for some(?) time. The attached patch seems to cure this.

I have only seen the problem in xserver 1.6, not 1.5 or master.

See also http://lists.freedesktop.org/archives/xorg-devel/2009-July/001387.html
where the patch was ack'ed by Peter Hutterer. Unfortunately the patch seems to be empty in the mail archive.
Comment 1 Kim Woelders 2009-08-02 09:33:34 UTC
Committed as b10c4fe343d2339bae4736793939e44a6befaf88, I see.
Thanks.


bug/show.html.tmpl processed on Jun 25, 2016 at 19:29:11.
(provided by the Example extension).