Bug 22985 - sample document with wrong linear gradient
Summary: sample document with wrong linear gradient
Status: RESOLVED FIXED
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-27 19:26 UTC by Jean-François Fortin Tam
Modified: 2009-07-30 01:12 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
test case (223.72 KB, application/pdf)
2009-07-27 19:26 UTC, Jean-François Fortin Tam
Details
screenshot (177.24 KB, image/png)
2009-07-27 19:29 UTC, Jean-François Fortin Tam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2009-07-27 19:26:36 UTC
Created attachment 28077 [details]
test case

Don't know if this is a duplicate of the various gradients bugs out there, but in the hope that this is useful and not yet reported, here's a sample file with a gradient on page 3 (the thermometer). It renders differently in Evince than in Acroread.
Comment 1 Jean-François Fortin Tam 2009-07-27 19:29:35 UTC
Created attachment 28079 [details]
screenshot

Evince (Poppler cairo 0.10.5) on the left vs Adobe Reader 9 on the right
Comment 2 James Cloos 2009-07-29 13:47:11 UTC
After comparing several this pdf on several renderers, and noting that mupdf also got it wrong — though in a different way than poppler does — I posted about it on gs’ bz.

Tor checked it and replied:

Tor> It’s an image not a linear gradient. I suspect it’s the same bug as 690666
Tor> where [mupdf’s] interpolation on the edges of images is wrong.

Comment 3 Carlos Garcia Campos 2009-07-30 01:12:12 UTC
Yes, this is indeed already fixed in git master. Thanks!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.