Bug 23021 - Add support for automake-1.11
Summary: Add support for automake-1.11
Alias: None
Product: at-spi2
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Mark Doffman
QA Contact:
Depends on:
Reported: 2009-07-29 08:41 UTC by Stephen Shaw
Modified: 2009-12-11 07:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Stephen Shaw 2009-07-29 08:41:38 UTC
Right now you have to have either 1.9 or 1.10 to build at-spi2-core.  openSUSE has moved to 1.11 for 11.2 and I'd assume other distributions will as well if they haven't already.

sshaw@stshaw:~/code/at-spi2-core> automake --version
automake (GNU automake) 1.11
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl-2.0.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Tom Tromey <tromey@redhat.com>
       and Alexandre Duret-Lutz <adl@gnu.org>.
sshaw@stshaw:~/code/at-spi2-core> sh autogen.sh 
checking for autoconf >= 2.53...
  testing autoconf2.50... not found.
  testing autoconf... found 2.63
checking for automake >= 1.9...
  testing automake-1.10... not found.
  testing automake-1.9... not found.
***Error***: You must have automake >= 1.9 installed
  to build Package.  Download the appropriate package for
  from your distribution or get the source tarball at
Comment 1 Mark Doffman 2009-12-11 07:23:13 UTC
The autogen scripts were updated on Oct 28th commits:

74e9ee1f9a1f808efde0d0e2470b04342a116d7a - at-spi2-atk
2ac0b99a4a50312190c953c75981d58c3        - at-spi2-core
57c036bd9bdfedeb16ea70a2e36e8e47fe9d1e9e - pyatspi2

The new scripts allow the use of automake 1.11.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.