Bug 23041 - Unable to upgrade package using pkcon
Summary: Unable to upgrade package using pkcon
Status: RESOLVED INVALID
Alias: None
Product: PackageKit
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-30 05:38 UTC by Priyank
Modified: 2012-01-05 10:45 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Priyank 2009-07-30 05:38:16 UTC
Overview:
If we have a package a.rpm installed, and we download the next version a.1.rpm then pkcon does not allow us to install the upgrade.

Also pkcon "upgrade" option does not accept file as an argument.

So there is no way to install the new version of the software.

Actual Results:
Unable to install the new version of the package.

Expected Results:
pkcon should upgrade the package.

Version:
PackageKit 0.3.6
OS: Ubuntu 8.10 
(But this is reproducible on most all the distributions that I tried)
Comment 1 Richard Hughes 2009-07-30 06:16:32 UTC
(In reply to comment #0)
> Also pkcon "upgrade" option does not accept file as an argument.

Right, you're supposed to use "pkcon install b.rpm" for files... doesn't this work?

Also, please don't set priority or severity -- they are for bug triagers and developers to use -- and I can assure you setting a bug to the highest priority in bugzilla has no affect on where it sits in my TODO.
Comment 2 Priyank 2009-07-30 06:18:54 UTC
pkcon install a.rpm works.

But after that if I download later version say a.1.rpm, that does not work.

pkcon install a.1.rpm
fails!

Sorry about the severity/priority, will skip it next time.
Comment 3 Richard Hughes 2009-07-30 07:00:36 UTC
(In reply to comment #2)
> pkcon install a.1.rpm
> fails!

How does it fail? You can get access to the debug log by using pkcon with the --verbose flag.
Comment 4 Priyank 2009-07-31 01:53:32 UTC
$ pkcon install ~/Desktop/opera-9.27-20080331.6-shared-qt.i386-en.rpm
-----------------------------------------------------------
Error: missing-gpg-signature: Package opera-9.27-20080331.6-shared-qt.i386-en.rpm is not signed
-----------------------------------------------------------

Package is installed. Try installing a new version

$pkcon install ~/Desktop/opera-9.64.gcc4-shared-qt3.i386.rpm
----------------------------------------------------------- 
Error: missing-gpg-signature: Package opera-9.64.gcc4-shared-qt3.i386.rpm is not signed
Error: package-download-failed: Errors were encountered while downloading packages.
qt3-3.3.8b-25.fc11.i586: Caching enabled but no local cache of /var/cache/yum/fedora/packages/qt3-3.3.8b-25.fc11.i586.rpm from fedora
-----------------------------------------------------------

The latest version does not update the older package.

Log:
-----------------------------------------------------------
TI:13:54:16	FI:egg-debug.c	FN:egg_debug_init,311
 - Verbose debugging 1 (on console 1)PK_VERBOSE
TI:13:54:16	FI:pk-client.c	FN:pk_client_connect,4350
 - connect
TI:13:54:16	FI:pk-client.c	FN:pk_client_connect,4350
 - connect
TI:13:54:16	FI:pk-client.c	FN:pk_client_connect,4350
 - connect
TI:13:54:16	FI:pk-client.c	FN:pk_client_connect,4350
 - connect
TI:13:54:16	FI:pk-console.c	FN:main,1898
 - filter=(null), filters=0
TI:13:54:16	FI:pk-client.c	FN:pk_client_connect,4350
 - connect
TI:13:54:16	FI:pk-client.c	FN:pk_client_set_tid,3934
 - set tid /202_cabddcda_data on 0x93fba70
TI:13:54:16	FI:pk-control.c	FN:pk_control_allocate_transaction_id,644
 - Got tid: '/202_cabddcda_data'
TI:13:54:16	FI:pk-client.c	FN:pk_client_set_tid,3934
 - set tid /202_cabddcda_data on 0x93fb810
TI:13:54:16	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed wait
TI:13:54:16	FI:pk-control.c	FN:pk_control_transaction_list_changed_cb,767
 - emit transaction-list-changed
TI:13:54:16	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed setup
TI:13:54:17	FI:pk-control.c	FN:pk_control_locked_cb,840
 - emit locked 1
TI:13:54:17	FI:pk-client.c	FN:pk_client_allow_cancel_cb,928
 - emit allow-cancel 0
TI:13:54:17	FI:pk-client.c	FN:pk_client_progress_changed_cb,578
 - emit progress-changed 0, 101, 515, 0
TI:13:54:17	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed running
TI:13:54:17	FI:pk-client.c	FN:pk_client_error_code_cb,916
 - emit error-code missing-gpg-signature, Package opera-9.64.gcc4-shared-qt3.i386.rpm is not signed
TI:13:54:17	FI:pk-console.c	FN:pk_console_error_code_cb,1430
 - need to try again with trusted FALSE
TI:13:54:17	FI:pk-client.c	FN:pk_client_connect,4350
 - connect
TI:13:54:17	FI:pk-client.c	FN:pk_client_set_tid,3934
 - set tid /203_bdeebdcb_data on 0x93fbb08
TI:13:54:17	FI:pk-control.c	FN:pk_control_allocate_transaction_id,644
 - Got tid: '/203_bdeebdcb_data'
TI:13:54:17	FI:pk-client.c	FN:pk_client_set_tid,3934
 - set tid /203_bdeebdcb_data on 0x93fb940
TI:13:54:17	FI:pk-client.c	FN:pk_client_error_refused_by_policy,263
 - ERROR: org.freedesktop.PackageKit.Transaction.RefusedByPolicy: org.freedesktop.packagekit.package-install-untrusted auth_admin
TI:13:54:19	FI:pk-client.c	FN:pk_client_error_auth_obtain,313
 - gained org.freedesktop.packagekit.package-install-untrusted privilege = 1
TI:13:54:19	FI:pk-client.c	FN:pk_client_connect,4350
 - connect
TI:13:54:19	FI:pk-client.c	FN:pk_client_set_tid,3934
 - set tid /204_ceccccca_data on 0x93fbba0
TI:13:54:19	FI:pk-control.c	FN:pk_control_allocate_transaction_id,644
 - Got tid: '/204_ceccccca_data'
TI:13:54:19	FI:pk-client.c	FN:pk_client_set_tid,3934
 - set tid /204_ceccccca_data on 0x93fb940
TI:13:54:19	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed wait
Error: missing-gpg-signature: Package opera-9.64.gcc4-shared-qt3.i386.rpm is not signed
TI:13:54:19	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed finished
TI:13:54:19	FI:pk-control.c	FN:pk_control_locked_cb,840
 - emit locked 0
TI:13:54:19	FI:pk-client.c	FN:pk_client_finished_cb,547
 - emit finished failed, 527
TI:13:54:19	FI:pk-console.c	FN:pk_console_finished_cb,566
 - install-files runtime was 0.5 seconds
TI:13:54:19	FI:pk-console.c	FN:pk_console_finished_cb,583
 - waiting for second install file to finish
TI:13:54:19	FI:pk-control.c	FN:pk_control_transaction_list_changed_cb,767
 - emit transaction-list-changed
TI:13:54:19	FI:pk-client.c	FN:pk_client_destroy_cb,522
 - emit destroy /204_ceccccca_data
TI:13:54:19	FI:pk-control.c	FN:pk_control_transaction_list_changed_cb,767
 - emit transaction-list-changed
TI:13:54:19	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed setup
TI:13:54:19	FI:pk-control.c	FN:pk_control_locked_cb,840
 - emit locked 1
TI:13:54:19	FI:pk-client.c	FN:pk_client_allow_cancel_cb,928
 - emit allow-cancel 0
TI:13:54:19	FI:pk-client.c	FN:pk_client_progress_changed_cb,578
 - emit progress-changed 0, 101, 48, 0
TI:13:54:19	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed running
TI:13:54:21	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed dep-resolve
TI:13:54:21	FI:pk-client.c	FN:pk_client_progress_changed_cb,578
 - emit progress-changed 5, 101, 2061, 0
TI:13:54:22	FI:pk-client.c	FN:pk_client_destroy_cb,522
 - emit destroy /202_cabddcda_data
TI:13:54:24	FI:pk-control.c	FN:pk_control_locked_cb,840
 - emit locked 0
TI:13:54:24	FI:pk-client.c	FN:pk_client_allow_cancel_cb,928
 - emit allow-cancel 1
TI:13:54:24	FI:pk-client.c	FN:pk_client_progress_changed_cb,578
 - emit progress-changed 10, 101, 4372, 0
TI:13:54:24	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed download
TI:13:54:24	FI:pk-client.c	FN:pk_client_error_code_cb,916
 - emit error-code package-download-failed, Errors were encountered while downloading packages.
qt3-3.3.8b-25.fc11.i586: Caching enabled but no local cache of /var/cache/yum/fedora/packages/qt3-3.3.8b-25.fc11.i586.rpm from fedora
TI:13:54:24	FI:pk-console.c	FN:pk_console_error_code_cb,1424
 - set requeue, but did not handle error
Error: package-download-failed: Errors were encountered while downloading packages.
qt3-3.3.8b-25.fc11.i586: Caching enabled but no local cache of /var/cache/yum/fedora/packages/qt3-3.3.8b-25.fc11.i586.rpm from fedora
TI:13:54:24	FI:pk-control.c	FN:pk_control_locked_cb,840
 - emit locked 1
TI:13:54:24	FI:pk-client.c	FN:pk_client_allow_cancel_cb,928
 - emit allow-cancel 0
TI:13:54:24	FI:pk-client.c	FN:pk_client_change_status,589
 - emit status-changed finished
TI:13:54:24	FI:pk-control.c	FN:pk_control_locked_cb,840
 - emit locked 0
TI:13:54:24	FI:pk-client.c	FN:pk_client_finished_cb,547
 - emit finished failed, 4386

-----------------------------------------------------------
Comment 5 Richard Hughes 2009-07-31 07:01:43 UTC
(In reply to comment #4)
> $ pkcon install ~/Desktop/opera-9.27-20080331.6-shared-qt.i386-en.rpm
> -----------------------------------------------------------
> Error: missing-gpg-signature: Package
> opera-9.27-20080331.6-shared-qt.i386-en.rpm is not signed
> -----------------------------------------------------------
> 
> Package is installed. Try installing a new version
> 
> $pkcon install ~/Desktop/opera-9.64.gcc4-shared-qt3.i386.rpm
> ----------------------------------------------------------- 
> Error: missing-gpg-signature: Package opera-9.64.gcc4-shared-qt3.i386.rpm is
> not signed
> Error: package-download-failed: Errors were encountered while downloading
> packages.
> qt3-3.3.8b-25.fc11.i586: Caching enabled but no local cache of
> /var/cache/yum/fedora/packages/qt3-3.3.8b-25.fc11.i586.rpm from fedora
> -----------------------------------------------------------
> 
> The latest version does not update the older package.

Right, it didn't install as it needed qt3 as a dep, which failed to download. Are you sure you're online when you try to upgrade?
Comment 6 Priyank 2009-07-31 07:07:36 UTC
You are right. My firewall seems to be blocking some ip addresses. It's working fine now. Thanks for looking into it.
Comment 7 Jean-François Fortin Tam 2012-01-05 10:45:49 UTC
Hi there,
This bug report is very old and based on a version not supported anymore. By upgrading to a newer version of PackageKit you could receive bug fixes and new functionality. You may need to upgrade your Linux distribution to obtain a newer version of PackageKit.
Please feel free to reopen this bug if the problem still occurs with the latest version.


bug/show.html.tmpl processed on Mar 25, 2017 at 23:35:02.
(provided by the Example extension).