Bug 2316 - Symbol noXFree86DRIExtension
Summary: Symbol noXFree86DRIExtension
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Ext/DRI (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high blocker
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2005-01-18 06:59 UTC by florian
Modified: 2005-10-18 22:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description florian 2005-01-18 06:59:49 UTC
Laptop Sony pcg-k215b
with ati radeon 345M igp
and Fedora Core 3 install.

--->direct rendering: Yes
    OpenGL renderer string:
    Mesa DRI Radeon 20030328 AGP 4x x86/MMX/SSE2  NO-TCL

When the lg3d-session is launching in console the X-server seems to be start and
failed with this error:
Symbol noXFree86DRIExtension from module
/usr/X11R6/lib/modules/extensions/libdri.a is unresolved!

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting 

(lg3d-session, project Looking Glass-JAVA)
Comment 1 Michel Dänzer 2005-01-18 08:43:37 UTC
Sounds like the X server binary was compiled without XF86DRI defined.
Comment 2 Adam Jackson 2005-01-18 08:57:38 UTC
it sounds more like he's running a server that doesn't have Roland's "have a
flag to disable every single extension individually" changes.  pretty sure the
lg3d server is one of those servers.
Comment 3 florian 2005-01-18 16:38:37 UTC
do you talk about the #1361 bug... it is not for disable Dri ?
I've downloading the last lg3d-X11 from the xorg cvs for lg3d...so, same 
For you, i must build the last xorg source on my system ?
Comment 4 florian 2005-01-20 10:15:06 UTC
I have compile the xorg cvs, and when i launch the lg3d-session: wonderfull, it
works...without dri...so it's, well no really that i want, no 3d acceleration
it's not the goal of the tiny user's match to get a good looking glass.
Well, I have tested to disable dri manually before that and the result was the
Thanks to read me and thanks for you work.
Comment 5 florian 2005-01-24 01:30:47 UTC
i solved my problem, i install the Nana Kofi Asumadu's package #314.
All works fine now.

*** This bug has been marked as a duplicate of 314 ***
Comment 6 florian 2005-01-24 01:34:05 UTC
i solved my problem, i install the Nana Kofi Asumadu's package #314.(bugs.xfree86)
All works fine now.
Comment 7 Adam Jackson 2005-08-30 09:33:24 UTC
reopen to hopefully deconfuse bugzilla...
Comment 8 Adam Jackson 2005-08-30 09:33:45 UTC

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.