Bug 23432 - [i830] X fails on splash screen with corruption (No valid modes)
Summary: [i830] X fails on splash screen with corruption (No valid modes)
Status: RESOLVED DUPLICATE of bug 17902
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-20 19:34 UTC by Bryce Harrington
Modified: 2009-09-14 20:21 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
XorgLog.txt (10.74 KB, text/plain)
2009-08-20 19:36 UTC, Bryce Harrington
no flags Details
XorgConf.txt (1.01 KB, text/plain)
2009-08-20 19:36 UTC, Bryce Harrington
no flags Details
BootDmesg.txt (46.68 KB, text/plain)
2009-08-20 19:36 UTC, Bryce Harrington
no flags Details
Lspci.txt (10.60 KB, text/plain)
2009-08-20 19:37 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2009-08-20 19:34:40 UTC
Forwarding this bug from Ubuntu reporter Robbt:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/408205

[Problem]
X fails to start up, reporting (EE) intel(0): No valid modes on this hardware.

Looks like it's not detecting anything connected to the VGA port for some reason?

[Original Description]
This bug has been around since the i810 package was removed from intrepid.
For some reason I thought it may have been fixed.

(EE) intel(0): tfp410 not detected got VID 1305: from DVOI2C_E Slave 112.
(II) Loading sub module "ch7017"
(II) LoadModule: "ch7017"
(II) Loading /usr/lib/xorg/modules/drivers//ch7017.so
(II) Module ch7017: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.0.0
	ABI class: X.Org Video Driver, version 5.0
(II) intel(0): I2C bus "DVOI2C_E" removed.
(II) intel(0): I2C bus "DVOI2C_E" initialized.
(II) intel(0): I2C bus "DVOI2C_E" removed.
(II) intel(0): I2C bus "DVODDC_D" removed.
(II) intel(0): I2C bus "CRTDDC_A" initialized.
(II) intel(0): I2C bus "CRTDDC_A" removed.
(II) intel(0): EDID for output VGA
(II) intel(0): Output VGA disconnected
(WW) intel(0): No outputs definitely connected, trying again...
(II) intel(0): Output VGA disconnected
(WW) intel(0): Unable to find initial modes
(EE) intel(0): No valid modes.



Architecture: i386
CurrentDmesg:
 [  128.398974] [drm] Initialized drm 1.1.0 20060810
 [  128.419960] pci 0000:00:02.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
 [  128.419974] pci 0000:00:02.0: setting latency timer to 64
 [  128.422321] [drm] Initialized i915 1.6.0 20080730 on minor 0
Date: Sun Aug  2 22:10:28 2009
DistroRelease: Ubuntu 9.10
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: FUJITSU LifeBook S Series
Package: xorg 1:7.4+3ubuntu5
ProcCmdLine: root=UUID=ada4ee78-0785-430f-8f74-f5454f389b00 ro  single nosplash
ProcEnviron:
 LANG=en_US.UTF-8ProcVersionSignature: Ubuntu 2.6.28-3.12-rt
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.5-1ubuntu1
 libdrm2 2.4.12-1ubuntu1
 xserver-xorg-video-intel 2:2.8.0-0ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu4
SourcePackage: xorg
Uname: Linux 2.6.28-3-rt i686
XorgLogOld:
 
dmi.bios.date: 05/19/2003
dmi.bios.vendor: Phoenix/FUJITSU
dmi.bios.version: Version 1.11
dmi.board.name: FJNB162
dmi.board.vendor: FUJITSU
dmi.chassis.type: 10
dmi.chassis.vendor: AFQ063A90BC01300
dmi.modalias: dmi:bvnPhoenix/FUJITSU:bvrVersion1.11:bd05/19/2003:svnFUJITSU:pnLifeBookSSeries:pvr:rvnFUJITSU:rnFJNB162:rvr:cvnAFQ063A90BC01300:ct10:cvr:
dmi.product.name: LifeBook S Series
dmi.sys.vendor: FUJITSU
setxkbmap: Error: command ['setxkbmap', '-print'] failed with exit code 255: Cannot open display "default display"
system: architecture:       i686kernel:             2.6.28-3-rt
Comment 1 Bryce Harrington 2009-08-20 19:36:22 UTC
Created attachment 28825 [details]
XorgLog.txt
Comment 2 Bryce Harrington 2009-08-20 19:36:35 UTC
Created attachment 28826 [details]
XorgConf.txt
Comment 3 Bryce Harrington 2009-08-20 19:36:47 UTC
Created attachment 28827 [details]
BootDmesg.txt
Comment 4 Bryce Harrington 2009-08-20 19:37:27 UTC
Created attachment 28828 [details]
Lspci.txt
Comment 5 Bryce Harrington 2009-08-20 19:38:12 UTC
Additional comments from the reporter:

"I booted into Linux again and added the 2.6.31-4 kernel and the problem is still occurring. It is actually failing at the splash screen at this point vs. when GDM is launched. It fills the screen with white and then becomes unresponsive. This problem has been around since Intrepid Ibix and I had switched to debian but ran into an Xorg problem when I switched from Lenny to the latest testing images. So I don't know of any workaround at this point and it could in fact be the same as this bug since it's similar hardware https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/362582. I have a Lifebook 6010 as someone else has in the bug I linked too."
Comment 6 Gordon Jin 2009-08-23 23:04:56 UTC
looks like bug#17902?
Comment 7 Gordon Jin 2009-09-14 20:21:26 UTC
I'm marking dup. Eric, please check.

*** This bug has been marked as a duplicate of bug 17902 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.