Bug 23538 - DiNovo Edge Zoom keys
Summary: DiNovo Edge Zoom keys
Status: RESOLVED DUPLICATE of bug 11227
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/evdev (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on: x11-keycode-limit
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 01:42 UTC by Peter Bengtsson
Modified: 2009-10-08 19:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
evtest for the 3 zoom related keys (9.05 KB, text/plain)
2009-08-27 01:42 UTC, Peter Bengtsson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Bengtsson 2009-08-27 01:42:19 UTC
Created attachment 28943 [details]
evtest for the 3 zoom related keys

X does not handle the zoom buttons (belonging to the touchpad device) on the DiNovo Edge keyboard.

I have attached the evtest for the keystrokes:

code 418: Zoom in (+) key
code 419: Zoom out (-) key
code 420: Zoom (%) key
Comment 1 Peter Hutterer 2009-08-27 01:47:43 UTC
Oh, that explains it. the server cannot process keycodes > 255 due to a
limitation in the core protocol.

This is being worked on with XI2 and XKB2, but it will take some time to
be fully useable.
Comment 2 Peter Hutterer 2009-10-08 19:27:33 UTC
looking at this again, the keycodes are the default codes from linux/input.h. No need to have a separate bug for this, this will be fixed once 11227 is resolved.

marking as duplicate.

*** This bug has been marked as a duplicate of bug 11227 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.