Bug 23553 - [945G v2.8* driver] Tiling problems
[945G v2.8* driver] Tiling problems
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
7.5
x86 (IA32) Linux (All)
: medium normal
Assigned To: Eric Anholt
: NEEDINFO
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 06:13 UTC by justin
Modified: 2009-12-10 14:22 UTC (History)
1 user (show)

See Also:


Attachments
Xorg.0.log (70.43 KB, text/plain)
2009-08-27 06:13 UTC, justin
Details
dmesg (29.64 KB, text/plain)
2009-08-27 06:14 UTC, justin
Details
xorg.conf (3.30 KB, text/plain)
2009-08-27 06:14 UTC, justin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description justin 2009-08-27 06:13:51 UTC
Created attachment 28949 [details]
Xorg.0.log

Bug description:
When using pymol[1], the graphics get worse after a second not touching the program.

picture:
http://dev.gentooexperimental.org/~jlec/paste/pymol.png

bad video:
http://dev.gentooexperimental.org/~jlec/paste/screen.mpg

This can be overcome with setting Option "Tiling" "false", so I think it is really related to Tiling.

System environment:
-- chipset: 945G
-- system architecture: 32bit
-- xf86-video-intel: 2.8.1, but it is the same since 2.7.9
-- xserver: 1.6.3.901, but the same in 1.6* at least.
-- mesa: 7.5
-- libdrm: 2.4.12
-- kernel: 2.6.30-gentoo-r4, but also with 2.6.29* and latest git sources
-- Linux distribution: gentoo
-- Machine or mobo model: desktop
-- Display connector: vga

Reproducing steps:
- Install pymol [1]
- fetch 3cwg
- wait a second

Additional info:

none
[1]
www.pymol.org
Comment 1 justin 2009-08-27 06:14:37 UTC
Created attachment 28950 [details]
dmesg
Comment 2 justin 2009-08-27 06:14:58 UTC
Created attachment 28951 [details]
xorg.conf
Comment 3 Eric Anholt 2009-10-30 17:38:17 UTC
Could you retest with Mesa master as of:

commit 7c8bed62e0165a0be3363f7abf81bf9e30341e00
Author: Eric Anholt <eric@anholt.net>
Date:   Fri Oct 30 15:33:11 2009 -0700

    intel: Use GTT mapping when available for swrast.
    
    This improves piglit quick.tests runtime from 19:33 minutes to 6:06 on
    my GM45.  It should also hide most of the A17 swizzling issues, though
    they'll still exist when swapping occurs (which is the kernel's problem
    either way).
Comment 4 justin 2009-11-02 03:54:19 UTC
It is solved with following revisions

 * Messages for package x11-libs/libdrm-9999:

 * GIT NEW clone -->
 *    repository: 		git://anongit.freedesktop.org/git/mesa/drm
 *    at the commit:		b0b96636dbf93445dd532b09b21fa4fc5ce6bdc7
 *    branch: 			master

 * Messages for package media-libs/mesa-9999:

 * GIT NEW clone -->
 *    repository: 		git://anongit.freedesktop.org/mesa/mesa
 *    at the commit:		87d7c1aa15a944d64e43b217e18553256f9fb681
 *    branch: 			master

Comment 5 justin 2009-11-02 12:06:20 UTC
Will this be backported to the 7.6 branch?
Comment 6 Eric Anholt 2009-12-10 14:22:01 UTC
It's kind of intrusive, so I don't plan to.