Bug 23587 - X drawing is a mess with KDE 4.3
Summary: X drawing is a mess with KDE 4.3
Status: NEW
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-28 21:48 UTC by mpapet
Modified: 2009-08-30 04:33 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (49.18 KB, text/plain)
2009-08-29 21:38 UTC, mpapet
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mpapet 2009-08-28 21:48:43 UTC
Drawing is a mess in KDE 4.3 with compositing enabled.  Using GTK/mozilla applications seems to make it *much* worse.

I'm running Debian Testing with Sid's xorg and KDE 4.3 packages.  No special builds.

See attached screen shot.  If you need more info, just let me know.
Comment 1 mpapet 2009-08-28 21:50:30 UTC
I don't know why, but the KDE project was *very* circumspect about the issue and suggested I open the bug here.https://bugs.kde.org/show_bug.cgi?id=205289

Comment 2 Michel Dänzer 2009-08-29 05:18:00 UTC
> If you need more info, just let me know.

As with any X related bug, please attach at least the full Xorg.0.log and xorg.conf (if any) files.
Comment 3 mpapet 2009-08-29 06:37:03 UTC
(In reply to comment #2)
> > If you need more info, just let me know.
> 
> As with any X related bug, please attach at least the full Xorg.0.log and
> xorg.conf (if any) files.
> 

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver      "radeon"
	VideoRam 65536
    	Option      "DRI"   "on"
	Option "DMAForXv" "true"
#	Option "EnablePageFlip" "true"
	Option "AGPMode" "4"
#	Option "AccelMethod" "EXA"
	Option		"DynamicClocks"	"on"
	 Option      "DirectRendering" "on"
#  Option "AGPFastWrite" "true"

EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection

Section "Module"
        Load  "dri"
	Load "glx"
	Load "dbe"
	Load "extmod"
	Load "int10"
	Load "ddc"
	Load "v4l"
EndSection

Section "DRI"
        Mode         0666
EndSection

Section "Extensions"
	Option "Composite" "1"
EndSection
Comment 4 mpapet 2009-08-29 21:33:31 UTC
(In reply to comment #2)
> > If you need more info, just let me know.
> 
> As with any X related bug, please attach at least the full Xorg.0.log and
> xorg.conf (if any) files.
> 

I don't know that this would help.

.xsession-errors

Xsession: X session started for mpapet at Sat Aug 29 21:14:56 PDT 2009
startkde: Starting up...
kdeinit4: preparing to launch /usr/lib/libkdeinit4_klauncher.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kded4.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kbuildsycoca4.so
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kbuildsycoca4.so
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kconf_update.so
Invalid D-BUS member name 'idle-hint' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'is-local' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'x11-display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'x11-display' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'display-device' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'remote-host-name' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'session-type' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
Invalid D-BUS member name 'unix-user' found in interface 'org.freedesktop.ConsoleKit.Session' while parsing introspection
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kcminit_startup.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_ksmserver.so
<unknown program name>(3223)/ KStartupInfo::createNewStartupId: creating:  "laptop;1251605705;479418;3223_TIME0" : "unnamed app"
X Error: XSyncBadAlarm 132
  Extension:    133 (Uknown extension)
  Minor opcode: 11 (Unknown request)
  Resource id:  0x0
X Error: XSyncBadAlarm 132
  Extension:    133 (Uknown extension)
  Minor opcode: 11 (Unknown request)
  Resource id:  0x0
kephald starting up 
XRANDR error base:  173 
RRInput mask is set!! 
RandRScreen::loadSettings - adding mode:  96 1024 x 768 
RandRScreen::loadSettings - adding mode:  97 1024 x 768 
RandRScreen::loadSettings - adding mode:  98 800 x 600 
RandRScreen::loadSettings - adding mode:  99 640 x 480 
RandRScreen::loadSettings - adding crtc:  90 
RandRScreen::loadSettings - adding crtc:  91 
RandRScreen::loadSettings - adding output:  92 
Setting CRTC 0 on output "VGA-0" (previous 0 ) 
RandRScreen::loadSettings - adding output:  93 
Setting CRTC 0 on output "DVI-0" (previous 0 ) 
RandRScreen::loadSettings - adding output:  94 
Setting CRTC 90 on output "LVDS" (previous 0 ) 
CRTC outputs: (94) 
Output name: "LVDS" 
Output refresh rate: 60.0038 
Output rect: QRect(0,0 1024x768) 
Output rotation: 1 
RandRScreen::loadSettings - adding output:  95 
Setting CRTC 0 on output "S-video" (previous 0 ) 
XRandROutputs::init 
  added output  92 
  added output  93 
  added output  94 
  added output  95 
output: "DVI-0" QRect(0,0 0x0) 0 false false 
output: "LVDS" QRect(0,0 1024x768) 0 false false 
output: "S-video" QRect(0,0 0x0) 0 false false 
output: "VGA-0" QRect(0,0 0x0) 0 false false 
load xml 
connected: 1 
looking for current "LVDS" 
known "*" has score: 0.25 
screen: 0 QRect(0,0 1024x768) 
looking for a matching configuration... 
connected: 1 
looking for current "LVDS" 
known "*" has score: 0.25 
found outputs, known: false 
connected: 1 
looking for current "LVDS" 
known "*" has score: 0.25 
activate external configuration!! 
registered the service: true 
screens registered on the bus: true 
outputs registered on the bus: true 
configurations registered on the bus: true 
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kglobalaccel.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_plasma-desktop.so
QDBusObjectPath: invalid path ""
kdeinit4: preparing to launch /usr/bin/knotify4
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
findServiceByDesktopPath: systemsettings not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/xorg.conf.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/gas.pdf.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/SS Decontrol - 01 - Glue.mp3.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/SS Decontrol - 02 - Forced Down Your Throat.mp3.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/SS Decontrol - 03 - Get It Away.mp3.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/SS Decontrol - 04 - Under the Influence.mp3.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/SS Decontrol - 05 - Nothing Done.mp3.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/SS Decontrol - 06 - Xclaim.mp3.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/SS Decontrol - 07 - No Reply.mp3.desktop not found
findServiceByDesktopPath: /home/mpapet/.kde/share/apps/RecentDocuments/circle one - patterns of force lp - 01 - social climbing leaches.mp3.desktop not found
QGraphicsGridLayout::itemAt: invalid index 0
QGraphicsGridLayout::itemAt: invalid index 2
QGraphicsGridLayout::itemAt: invalid index 6
Invalid D-BUS interface name 'org.kde.plasma-desktop.PlasmaApp' found while parsing introspection
kdeinit4: preparing to launch /usr/lib/kde4/kio_trash.so
kdeinit4: preparing to launch /usr/bin/kwrited
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kaccess.so
<unknown program name>(3302)/ kdemain: Xlib XKB extension major= 1  minor= 0
QFile::remove: Empty or null file name
QFile::remove: Empty or null file name
kdeinit4: preparing to launch /usr/lib/libkdeinit4_krunner.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_nepomukserver.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kmixctrl.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_nepomukserver.so
Nepomuk server already running.
[/usr/bin/nepomukservicestub] (Soprano::Redland::BackendPlugin) creating model of type "hashes" with options "hash-type='bdb',contexts='yes',dir='/home/mpapet/.kde/share/apps/nepomuk/repository/main/data/redland'"
[/usr/bin/nepomukservicestub] (ServerCore) new socket connection.
kdeinit4: preparing to launch /usr/bin/nepomukservicestub
<unknown program name>(3308)/: Communication problem with  "krunner" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." " 

[/usr/bin/nepomukservicestub] (ServerCore) new socket connection.
kdeinit4: preparing to launch /usr/bin/nepomukservicestub
findServiceByDesktopPath:  not found
Unknown service name: 10dbd17074000125151828300000046480007_1251521541_9798
kdeinit4: preparing to launch /usr/bin/nepomukservicestub
Unknown service name: 10dbd17074000125151828400000046480008_1251521541_10114
kdeinit4: preparing to launch /usr/lib/kde4/kio_trash.so
kdeinit4: preparing to launch /usr/bin/nepomukservicestub
Unknown service name: 10dbd17074000125151828400000046480009_1251521541_10421
Unknown service name: 10dbd17074000125151828400000046480011_1251521541_10727
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kmix.so
kdeinit4: preparing to launch /usr/bin/kopete
[/usr/bin/nepomukservicestub] (ServerCore) new socket connection. 
(ServerCore) new socket connection. 
(ServerCore) new socket connection.
Application '/usr/bin/nepomukservicestub' exited normally...
[/usr/bin/nepomukservicestub] Removing connection
kdeinit4: preparing to launch /usr/bin/amarok
kdeinit4: preparing to launch /usr/bin/knetworkmanager
kdeinit4: preparing to launch /usr/bin/kerneloops-applet
kdeinit4: preparing to launch /usr/bin/knetworkmanager
kdeinit4: preparing to launch /usr/lib/libkdeinit4_klipper.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kmix.so
QPainter::begin: Cannot paint on a null pixmap
QPainter::translate: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Cannot paint on a null pixmap
QPainter::translate: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Cannot paint on a null pixmap
QPainter::translate: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Cannot paint on a null pixmap
QPainter::translate: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Cannot paint on a null pixmap
QPainter::translate: Painter not active
QPainter::end: Painter not active, aborted
QPainter::begin: Cannot paint on a null pixmap
QPainter::translate: Painter not active
QPainter::end: Painter not active, aborted
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
<unknown program name>(3337)/: Communication problem with  "amarok" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." " 

ALSA lib setup.c:555:(add_elem) Cannot obtain info for CTL elem (MIXER,'IEC958 Playback Default',0,0,0): No such file or directory
Calling appendChild() on a null node does nothing.
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
Object::connect: No such signal KLineEdit::downPressed()
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
HTTP GET "http://post.audioscrobbler.com/?hs=true&p=1.2.1&c=ark&v=2.1.1&u=mpapet&t=1251605748&a=5c50aef6f43d600752589c4eaf5c8322&api_key=402d3ca8e9bc9d3cf9b85e1202944ca5&sk=6470837c455cdd69f81e2fb48675fe8f" 
Couldn't resolve property: linearGradient5167
link XMLID_9_ hasn't been detected!
Couldn't resolve property: linearGradient3563
link XMLID_9_ hasn't been detected!
link XMLID_9_ hasn't been detected!
link XMLID_9_ hasn't been detected!
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_trash.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_http.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_http.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_http.so
kdeinit4: preparing to launch /usr/lib/kde4/kio_http.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kio_http_cache_cleaner.so
DCOPClient::attachInternal. Attach failed Could not open network socket
DCOPClient::attachInternal. Attach failed Could not open network socket
kbuildsycoca running...
kdeinit4: preparing to launch /usr/lib/kde4/kio_file.so
":" 
  QUrl( "" )  
 "" 
":" 
  QUrl( "" )  
 "" 
WARNING: GOT NULL NODE IN COPY CONSTRUCTOR! 
WARNING: GOT NULL NODE IN COPY CONSTRUCTOR! 
WARNING: GOT NULL NODE IN COPY CONSTRUCTOR! 
WARNING: GOT NULL NODE IN COPY CONSTRUCTOR! 
":" 
  QUrl( "" )  
 "" 
WARNING: GOT NULL NODE IN COPY CONSTRUCTOR! 
WARNING: GOT NULL NODE IN COPY CONSTRUCTOR! 
WARNING: GOT NULL NODE IN COPY CONSTRUCTOR! 
WARNING: GOT NULL NODE IN COPY CONSTRUCTOR! 
"" 
Will retry in 60 seconds 
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kconf_update.so
kdeinit4: preparing to launch /usr/lib/libkdeinit4_kconf_update.so
Launched ok, pid = 3399

Comment 5 mpapet 2009-08-29 21:38:48 UTC
Created attachment 29021 [details]
Xorg.0.log

Xorg.0.log attached.  FYI, same bug(s?) prior version.  I opened the bug on Debian's Sid and this is from Debian Testing.
Comment 6 Michel Dänzer 2009-08-30 04:33:22 UTC
Please always attach files, do not paste them as comments, to keep bug reports tidy. Also, please set MIME type text/plain for text attachments.

From the log file:

(II) RADEON(0): Video RAM override, using 65536 kB instead of 32768 kB

Does it work better if you don't tell the driver to use more VRAM than there actually is on the card? (Disable the VideoRam directive)

If not, please try disabling the AGPMode and DynamicClocks options, and if that still doesn't help, please try enabling EXA.

Please try all of this with the newer X packages (as well).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.