Bug 23594 - [G45] Mutter causes GPU hang
[G45] Mutter causes GPU hang
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other All
: high critical
Assigned To: Eric Anholt
: NEEDINFO
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-30 06:20 UTC by Sven Arvidsson
Modified: 2009-09-10 07:40 UTC (History)
0 users

See Also:


Attachments
gpu dump (136.26 KB, application/x-gzip)
2009-08-30 06:20 UTC, Sven Arvidsson
Details
dmesg output (46.72 KB, text/plain)
2009-08-30 06:20 UTC, Sven Arvidsson
Details
xorg log (48.37 KB, text/plain)
2009-08-30 06:20 UTC, Sven Arvidsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Arvidsson 2009-08-30 06:20:23 UTC
Created attachment 29022 [details]
gpu dump

Mutter (the compositing manager for GNOME 3) is an excellent way to cause GPU hangs. The following hang was caused by running Mutter and OpenArena, but pretty much any gl app more advanced than glxgears will cause a hang when Mutter is used.

[   94.888078] render error detected, EIR: 0x00000010
[   94.888082]   IPEIR: 0x00000000
[   94.888084]   IPEHR: 0x60020100
[   94.888085]   INSTDONE: 0x808fffff
[   94.888087]   INSTPS: 0x0001f02e
[   94.888089]   INSTDONE1: 0x999fffa2
[   94.888090]   ACTHD: 0x0a173450
[   94.888092] page table error
[   94.888094]   PGTBL_ER: 0x01000000
[   94.888097] [drm:i915_handle_error] *ERROR* EIR stuck: 0x00000010, masking

System environment:
-- chipset: G45 / ICH10R
-- system architecture: 32-bit
-- Linux distribution: Debian unstable
-- Machine or mobo model: Asus P5Q-EM
-- Display connector: DVI
-- KMS: enabled
-- xf86-video-intel: 7c48c21b22bf5862c5a35bda1635753cc5a7197c
-- xserver: 1.6.3
-- mesa: 3c1172f06636ff4aec24a6c68df937844da73a53
-- drm: 73b59c894380995a2889b98e79acadd2da0bb237
-- kernel: 2.6.31-rc8 (debian)
Comment 1 Sven Arvidsson 2009-08-30 06:20:41 UTC
Created attachment 29023 [details]
dmesg output
Comment 2 Sven Arvidsson 2009-08-30 06:20:59 UTC
Created attachment 29024 [details]
xorg log
Comment 3 Eric Anholt 2009-09-09 14:18:15 UTC
May be worthwhile to retest with:

commit 5604b27b9326ac542069a49ed9650c4b0d3e939a
Author: Eric Anholt <eric@anholt.net>
Date:   Wed Sep 9 12:35:30 2009 -0700

    i965: Fix relocation delta for WM surfaces.
    
    This was a regression in 0f328c90dbc893e15005f2ab441d309c1c176245
    
    Bug #23688
    Bug #23254

as mutter repaints the whole screen every frame, so it'll tend to hit the working set > aperture case earlier than, say, compiz.
Comment 4 Sven Arvidsson 2009-09-10 07:40:07 UTC
Indeed it does. Thanks!