Bug 2362 - Lock ups w/ dri, xv, v4l. Radeon 9000/9100/9200-series.
Summary: Lock ups w/ dri, xv, v4l. Radeon 9000/9100/9200-series.
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-23 15:22 UTC by Jonathan Isom
Modified: 2007-12-17 10:41 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Isom 2005-01-23 15:22:25 UTC
After Upgrading from 6.8.1 to XORG-6_8_1_902 the Computer locks up hard.
I tested with kdetv & xawtv.  It takes anywhere from a few seconds to 
a few minutes of tv watching to lock up.  This doesn't affect non-Xv
overlay or Xv PutImage.
Comment 1 Jonathan Isom 2005-03-27 19:08:55 UTC
After Upgrading to 6.8.2 
the Computer continues to locks up hard. 
I tested with xawtv.  
It takes anywhere from a few seconds to 
 a few minutes of tv watching to lock up. 
 This doesn't affect Xv PutImage
  or appear to affect non-Xv overly.
Comment 2 Paul Osmialowski 2005-04-15 10:57:44 UTC
The same problem on athlon64 3000+ 754 socket, 512MB RAM, radeon 9250 128mb, bt848
I'm not sure if problem is V4L module related, I guess it's a problem with
overlay on radeons. My modules section in xorg.conf looks like:
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection
Comment 3 Dmitry Butskoy 2005-07-09 00:51:00 UTC
  I have the same problem with xawtv and radeon 7000 (lspci: "ATI Technologies
Inc Radeon RV100 QY [Radeon 7000/VE]").
  But it is not related to xawtv (or watching TV at all) only. The same is just
for "glxgears" command. It works fine some seconds, and then computer locks up
hard (freeze).
Comment 4 Dmitry Butskoy 2005-07-09 01:27:28 UTC
  There is a temporary fix for this problem: just comment out "Load "dri"" in
xorg.conf . Both xawtv and glxgears work fine after this.
Comment 5 Dmitry Butskoy 2005-07-11 22:25:52 UTC
  But there is a difference for xawtv and glxgears here: for glxgears we can set
"Option "SWCursor" "yes"" to avoid freeze (see
http://bugs.freedesktop.org/show_bug.cgi?id=3606), but it not help for xawtv
case :-(
Comment 6 T. Hood 2005-09-25 04:04:36 UTC
Submitter: Does disabling dri cure your lockups?
Comment 7 Jonathan Isom 2005-09-26 16:11:30 UTC
Currently running XORG-6_99_99_900 on linux 2.6.13.2.
with dri disabled it doesn't lock up.  

Additionally  there is a regression. Xv v4l used to scale to the max 
resolution,  now only to the v4l device max(Not sure 
thats a bug or feature change).
Comment 8 T. Hood 2005-09-28 02:10:14 UTC
*** Bug 3606 has been marked as a duplicate of this bug. ***
Comment 9 Jonathan Isom 2005-12-19 13:30:04 UTC
By christmas i'll have a nvidia card so
I won't be able to follow up on this bug.
Comment 10 Michel Dänzer 2006-05-09 03:45:44 UTC
Does this still happen with current versions of xf86-video-ati and Mesa?
Comment 11 Erik Andren 2006-05-10 06:28:04 UTC
Ping!
Comment 12 Erik Andren 2006-07-28 10:35:20 UTC
Closing due the lack of activity from the bug poster.
Comment 13 Dmitry Butskoy 2007-01-09 07:39:08 UTC
The problem still exist, with xorg-x11-7.0, under Fedora Core 5.

Xawtv crashed as usual, glxgears seems to not.
Comment 14 Timo Jyrinki 2007-02-25 04:33:30 UTC
Please test a patch (=workaround) that is linked to in bug 5986.

For Radeon 7000 -series (and probably Mobility M6 as well), lockup issues are discussed in bug 3606. The problems with those might be caused by the same problem, but it has not yet been proved.
Comment 15 Daniel Stone 2007-02-27 01:25:13 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 16 Timo Jyrinki 2007-12-17 02:57:58 UTC
Dmitry, can you try if everything works in the new Fedora 8? It has drivers that have seen quite a lot of bug fixes since Fedora Core 5.

The original bug reporter is apparently already in the nvidia land, so he cannot help to test here.
Comment 17 Dmitry Butskoy 2007-12-17 04:59:16 UTC
Well,

Since I've updated to xorg-x11-drv-ati-6.6.3 (even still under Fedora Core 5), the problem is gone. No more crashes etc.

It seems it can be closed now. :)
Comment 18 Julien Cristau 2007-12-17 10:41:51 UTC
Thanks for following up, Dmitry! Marking as fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.